Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1011648

Summary: Atlas segfaults on arm
Product: [Fedora] Fedora Reporter: Orion Poplawski <orion>
Component: atlasAssignee: Deji Akingunola <dakingun>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: rawhideCC: c.david86, dakingun, fkluknav, loganjerry, susi.lehtola
Target Milestone: ---   
Target Release: ---   
Hardware: arm   
OS: Linux   
URL: https://sourceforge.net/p/math-atlas/support-requests/922/
Whiteboard:
Fixed In Version: 3.10.1-5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-10-03 18:41:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 245418    

Description Orion Poplawski 2013-09-24 17:37:36 UTC
Description of problem:

atlas is segfaulting on arm.  Enabled tests in atlas package to help figure it out.  See http://koji.fedoraproject.org/koji/taskinfo?taskID=5973628

/builddir/build/BUILD/ATLAS/arm_base/bin/ATLrun.sh: line 4:  9493 Segmentation fault      $atldir/$*

Version-Release number of selected component (if applicable):
atlas-3.10.1

Comment 1 Orion Poplawski 2013-10-03 02:45:32 UTC
I'm building an updated atlas package now.  It adds a missing -DATL_ARM_HARDFP=1 as specified here: http://math-atlas.sourceforge.net/errata.html#armhardfp.  I've also changed to setting the compiler flags as mentioned there for consistency and some clarity (it avoids duplication of flags on the compile line).

It appears that this may have fixed the segfault.  The checks still fail though as seen in this scratch build log: http://kojipkgs.fedoraproject.org//work/tasks/7648/6017648/build.log, so I've kept the arm test disabled for now.

Comment 2 Orion Poplawski 2013-10-03 18:41:08 UTC
I'm calling this fixed with 3.10.1-5

Comment 3 Jerry James 2013-10-03 18:53:37 UTC
Thanks for fixing this, Orion.  It seems to be working for me, too.