Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1012014

Summary: Pandaboard is unable to boot with 3.11+ kernels
Product: [Fedora] Fedora Reporter: Paul Whalen <pwhalen>
Component: arm-boot-configAssignee: Brendan Conoboy <blc>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: blc, dennis, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, marcelo.barbosa, pbrobinson, sboyce
Target Milestone: ---   
Target Release: ---   
Hardware: arm   
OS: Linux   
Whiteboard:
Fixed In Version: arm-boot-config-0.62-1.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-03-14 15:05:53 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 245418    

Description Paul Whalen 2013-09-25 14:43:43 UTC
Description of problem:
As of the 3.11 kernel the Pandaboard no longer boots the unified kernel. Attempted using the DTB and without. The issue seems to involve loading the 
initramfs - when the kernel and dtb are used the kernel boots. 


Version-Release number of selected component (if applicable):

3.11+

How reproducible:

everytime

Steps to Reproduce:
1. Boot Fedora 20 Alpha with the Pandaboard

Actual results:
System will display "Starting kernel ..' with no further output. 

Expected results:
Fedora 20 Alpha 

Additional info:

Comment 1 Justin M. Forbes 2014-02-24 14:04:29 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.13.4-200.fc20.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 2 Peter Robinson 2014-03-11 00:15:26 UTC
So this is now booting with 3.14rc5 if you use an appended dtb to the kernel. We're looking at why this might not be working.

Comment 3 Peter Robinson 2014-03-14 00:39:50 UTC
Turns out this was a minor issue of a few uboot commands... just need to get the right ones :)

Comment 4 Brendan Conoboy 2014-03-14 15:05:53 UTC
Fixed as of arm-boot-config-0.62

Comment 5 Fedora Update System 2014-03-16 19:30:13 UTC
arm-boot-config-0.62-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/arm-boot-config-0.62-1.fc20

Comment 6 Fedora Update System 2014-03-26 05:33:31 UTC
arm-boot-config-0.62-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.