Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1021142

Summary: devscripts 2.13.4-3 not built with $RPM_{OPT,LD}_FLAGS
Product: [Fedora] Fedora Reporter: Ville Skyttä <ville.skytta>
Component: devscriptsAssignee: Sandro Mani <manisandro>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: ignatenko, manisandro
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: devscripts-2.13.4-4.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-11-10 06:19:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 496968    

Description Ville Skyttä 2013-10-19 19:24:06 UTC
devscripts 2.13.4-3 is not built with $RPM_{OPT,LD}_FLAGS, see the cc lines in the build log. Also, scripts/Makefile uses dpkg-buildflags to get CFLAGS and LDFLAGS so maybe a build dep on dpkg-dev should be added.

Comment 1 Sandro Mani 2013-10-19 20:24:02 UTC
Thanks for catching this. dpkg-buildflags --get CFLAGS does not return %{optflags}, so I added CFLAGS="%{optflags}" to the makefile.

Comment 2 Fedora Update System 2013-10-19 22:11:55 UTC
devscripts-2.13.4-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/devscripts-2.13.4-4.fc20

Comment 3 Ville Skyttä 2013-10-20 07:17:24 UTC
It's still not being built with $RPM_LD_FLAGS, but that's a minor issue since the Fedora ld defaults are effectively the same. I'd fix it anyway.

Comment 4 Sandro Mani 2013-10-20 09:57:46 UTC
What is the macro for $RPM_LD_FLAGS, or does no such macro exist? Btw: since I'm going to rebuild again, I'm going to add Obsoletes: rpmdevtools < 8.4, can you do it as well in rpmdevtools?

Comment 5 Ville Skyttä 2013-10-20 10:13:12 UTC
I suppose some kind of an kldugy macro version of $RPM_LD_FLAGS exists, but I don't remember it and would just use the shell var.

Wrt the devscripts<->rpmdevtools stuff, I'm done with it and will leave rpmdevtools 8.4-2 as it is now, I don't have any more time or interest for that hackery.

Comment 6 Sandro Mani 2013-10-20 10:21:17 UTC
Ok, fair enough. Thanks for you patience.

Comment 7 Fedora Update System 2013-10-20 11:19:41 UTC
devscripts-2.13.4-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/devscripts-2.13.4-5.fc20

Comment 8 Fedora Update System 2013-10-20 17:46:39 UTC
Package devscripts-2.13.4-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing devscripts-2.13.4-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19555/devscripts-2.13.4-5.fc20
then log in and leave karma (feedback).

Comment 9 Igor Gnatenko 2013-10-21 09:26:56 UTC
Why not:
%prep
echo '#!/bin/sh' > ./configure
chmod +x ./configure

%build
%configure

?


http://pkgs.fedoraproject.org/cgit/gmqcc.git/tree/gmqcc.spec

Comment 10 Ville Skyttä 2013-10-21 09:33:49 UTC
Heh, that's a clever hack :). One could "clean it up" even a bit more by just forgetting about the %prep stuff altogether and doing something like this instead:

    %build
    %configure 2>/dev/null || : # just for setting *FLAGS

But I suppose it wouldn't work for this package as IIRC it doesn't honor *FLAGS from the environment, they need to be passed as arguments to make.

Comment 11 Sandro Mani 2013-10-21 12:09:14 UTC
Correct, it does not work.

Comment 12 Fedora Update System 2013-11-10 06:19:26 UTC
devscripts-2.13.4-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2013-11-10 07:47:17 UTC
devscripts-2.13.4-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.