Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1140867

Summary: ExcludeArch: arm applies to entire package, not just subpackage; breaks several deps for ARM
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: avroAssignee: Peter Robinson <pbrobinson>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 21CC: dennis, jcm, mgoldman, pbrobinson, ricardo.arguello, robatino, rrati
Target Milestone: ---   
Target Release: ---   
Hardware: arm   
OS: Linux   
Whiteboard: AcceptedBlocker
Fixed In Version: avro-1.7.5-9.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-23 02:42:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1043119    

Description Adam Williamson 2014-09-11 21:41:44 UTC
avro.spec has this chunk:

%package mapred
Summary:          Apache Avro Mapred API
Requires:         hadoop-client
Requires:         hadoop-mapreduce

# Hadoop is not available on ARM (yet)
# https://bugzilla.redhat.com/show_bug.cgi?id=999971
ExcludeArch:      %{arm}

which is clearly meant to exclude just avro-mapred from the ARM arch. However, this doesn't work. ExcludeArch takes effect at the .src.rpm level, it cannot be applied to subpackages. The effect of the directive is that all avro packages are missing from the ARM tree. (You can verify this by just looking in https://dl.fedoraproject.org/pub/fedora/linux/development/21/armhfp/os/Packages/a/ ).

Various things have a dep on mvn(org.apache.avro:avro), which avro itself provides:

hadoop-common-0:2.4.1-2.fc21.noarch
hadoop-mapreduce-0:2.4.1-2.fc21.noarch
hadoop-tests-0:2.4.1-2.fc21.noarch
hibernate-search-0:4.5.1-4.fc21.noarch
wildfly-0:8.1.0-3.fc21.noarch

all of those have their dep chains broken for ARM by this issue, because avro is not available. This is affecting Fedora 21 Alpha - note in https://fedorahosted.org/rel-eng/ticket/5940#comment:9 the various repoclosure issues caused by this.

Marking as an automatic AlphaBlocker: repoclosure issues are automatic blockers per https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Automatic_blockers , "Unresolved dependencies on the DVD image (failures of QA:Testcase_Mediakit_Repoclosure)"

This would break, for instance, trying to install the "Java Application Server" group on ARM.

Comment 1 Peter Robinson 2014-09-12 10:39:53 UTC
Yes, it's something I've been aware of for a while (breaks free-ipa server install) and I've been meaning to fix the hadoop build but not had enough round-tuits. I'll fix this package in the short term and then update it again once I've fixed hadoop.

Comment 2 Fedora Update System 2014-09-12 12:07:04 UTC
avro-1.7.5-9.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/avro-1.7.5-9.fc21

Comment 3 Fedora Update System 2014-09-12 17:47:32 UTC
Package avro-1.7.5-9.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing avro-1.7.5-9.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10771/avro-1.7.5-9.fc21
then log in and leave karma (feedback).

Comment 4 Adam Williamson 2014-09-16 15:25:06 UTC
RC1 compose request report indicates no repoclosure issues:

https://fedorahosted.org/rel-eng/ticket/5940#comment:14

therefore this is fixed.

Comment 5 Fedora Update System 2014-09-23 02:42:03 UTC
avro-1.7.5-9.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.