Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at

Bug 1163481

Summary: F21 aarch64 compose fails to find gcdaa64.efi
Product: [Fedora] Fedora Reporter: D. Marlin <dmarlin>
Component: grub2Assignee: Peter Jones <pjones>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: bcl, crobinso, lkundrak, mads, pjones, pwhalen
Target Milestone: ---   
Target Release: ---   
Hardware: aarch64   
OS: Linux   
Fixed In Version: grub2-2.02-0.12.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-12-06 10:46:27 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 922257    

Description D. Marlin 2014-11-12 19:21:55 UTC
Description of problem:

F21 aarch64 compose fails when it does not find gcdaa64.efi:

  IOError: nothing matching /var/tmp/lorax.1EY_9N/installroot/boot/efi/EFI/*/gcdaa64.efi in /

This file needs to be added to the grub2-efi package.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  run a compose using lorax for F21 on aarch64

Actual results:

2014-11-12 12:00:42,295:   install boot/efi/EFI/*/gcdaa64.efi EFI/BOOT/grubaa64.efi
  install boot/efi/EFI/*/gcdaa64.efi EFI/BOOT/grubaa64.efi
2014-11-12 12:00:42,303:   IOError: nothing matching /var/tmp/lorax.1EY_9N/installroot/boot/efi/EFI/*/gcdaa64.efi in /
  IOError: nothing matching /var/tmp/lorax.1EY_9N/installroot/boot/efi/EFI/*/gcdaa64.efi in /
Traceback (most recent call last):
  File "/usr/sbin/lorax", line 311, in <module>
  File "/usr/sbin/lorax", line 210, in main
  File "/usr/lib/python2.7/site-packages/pylorax/", line 343, in run
  File "/usr/lib/python2.7/site-packages/pylorax/", line 239, in build, kernels=self.kernels)
  File "/usr/lib/python2.7/site-packages/pylorax/", line 181, in run
  File "/usr/lib/python2.7/site-packages/pylorax/", line 200, in _run
  File "/usr/lib/python2.7/site-packages/pylorax/", line 233, in install
    for src in rglob(self._in(srcglob), fatal=True):
  File "/usr/lib/python2.7/site-packages/pylorax/", line 95, in rglob
    raise IOError("nothing matching %s in %s" % (pathname, root))
IOError: nothing matching /var/tmp/lorax.1EY_9N/installroot/boot/efi/EFI/*/gcdaa64.efi in /

Expected results:

Compose completes without error.

Additional info:

Comment 1 Brian Lane 2014-11-12 23:55:07 UTC
This should be fixed when builds start working. The current build issue is that there are several modules that aren't supported on aarch64. I tried a simple patch for backtrace but found that usb wasn't working either. I'm not sure if that's something that needs to be enabled for aarch64 or if it just isn't supported in grub.

build.log from a scratch build with backtrace module removed on aarch64:

Comment 2 D. Marlin 2014-11-13 02:20:27 UTC
(In reply to bcl from comment #1)
>  I tried a
> simple patch for backtrace but found that usb wasn't working either. I'm not
> sure if that's something that needs to be enabled for aarch64 or if it just
> isn't supported in grub.

If I understand correctly, USB is not quite supported on aarch64 yet (kernel driver work is still in progress).  I'm not sure if this is the cause of the error you encountered.

Comment 3 Fedora Update System 2014-11-20 16:42:09 UTC
grub2-2.02-0.12.fc21 has been submitted as an update for Fedora 21.

Comment 4 Cole Robinson 2014-11-20 20:57:46 UTC
I think this is preventing the F21 aarch64 GA media from booting with no user intervention with qemu-system-aarch64 + uefi. I'll confirm it's fixed when the next compose appears

Comment 5 Fedora Update System 2014-11-22 20:22:04 UTC
Package grub2-2.02-0.12.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing grub2-2.02-0.12.fc21'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-12-06 10:46:27 UTC
grub2-2.02-0.12.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.