Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1177662

Summary: unreadable text in meld under KDE
Product: [Fedora] Fedora Reporter: Damian Wrobel <dwrobel>
Component: meldAssignee: Dominic Hopf <dmaphy>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: brpocock, c.david86, cwickert, dmaphy, dvratil, extras-orphan, jgrulich, john.haxby, jreznik, kevin, ltinkl, mbriza, pahan, rdieter, rnovacek, ry, smparrish, than
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: meld-3.12.3-1.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-02-03 12:03:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
meld screenshot
none
meld-3.13-screenshot none

Description Damian Wrobel 2014-12-29 18:05:01 UTC
Created attachment 974134 [details]
meld screenshot

Description of problem:
File comparision in meld is unreadable under KDE (see attached screenshot).

Version-Release number of selected component (if applicable):
$ rpm -qv meld
meld-3.12.1-1.fc21.noarch

kde: 4.14.3 (fully updated to updates-testing as of now).

How reproducible:
100%


Steps to Reproduce (just to be sure we're using defaults):
1. Create a new user 'kdetest'
2. Login as 'kdetest' using 'KDE Plasma Workspace'
3. launch 'meld' /etc/services /etc/services

Actual results:
Text to compare is unreadable.

Expected results:
Text should be readable.

Additional info:
On F20 there wasn't such an issue.

Comment 1 Rex Dieter 2014-12-29 18:13:07 UTC
Triaging to kde-workspace for now, though this is more likely a change in meld (kde differences between f20 and f21 are very minor)

Comment 2 Damian Wrobel 2014-12-29 18:19:14 UTC
Seems to similar to bug #1118898.

Comment 3 Rex Dieter 2014-12-29 18:31:58 UTC
I would argue this is a meld bug, it seems to unconditionally use a black background for unchanged text, regardless of active color scheme (which obviously can lead to problems if text contrast vs. this hard-coded black is too low)

Re-assigning...

Comment 4 Damian Wrobel 2014-12-29 19:17:24 UTC
Created attachment 974157 [details]
meld-3.13-screenshot

I followed [1] and have cloned the latest meld sources and the issue seems to be fixed (git: 936b6ab).

[1] http://comments.gmane.org/gmane.comp.gnome.meld.general/2241

Comment 5 Pavel Alexeev 2015-01-12 15:40:53 UTC
I also could reproduce it and it is very annoying (unchanged text is not visible at all).

Possibly it is introduced by:
https://mail.gnome.org/archives/commits-list/2014-October/msg01998.html
https://mail.gnome.org/archives/commits-list/2014-October/msg05560.html

I also tried and commenting lines:
        fixes_provider.load_from_data(
            "MeldSourceView { background-color: rgba(0.0, 0.0, 0.0, 0.0); } "
            "MeldSourceView:selected { background-color: %s; } " % color)
in /usr/bin/meld solve problem for me.

I've attach screenshot how it looks by default.

Comment 6 Damian Wrobel 2015-01-13 16:41:11 UTC
Please try to use the 3.13 [2] version from koji.

[2] http://koji.fedoraproject.org/koji/buildinfo?buildID=602522

Comment 7 Bruce-Robert Pocock 2015-01-19 21:40:16 UTC
+1 on fix:

Same thing occurring in stock Gnome-3 desktop as well. (Upgraded system from ƒ20, not clean install, however.) Identical presentation (solid black outside of diff regions; text visible when highlighted). Koji build meld.noarch 0:3.13.0-1.fc22 → works fine.

Comment 8 john.haxby@oracle.com 2015-01-23 11:58:52 UTC
This is fixed in upstream meld 3.12.3.  Any chance of pushing out an update?

Comment 9 Fedora Update System 2015-01-23 16:59:17 UTC
meld-3.12.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/meld-3.12.3-1.fc21

Comment 10 Fedora Update System 2015-01-26 02:31:51 UTC
Package meld-3.12.3-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing meld-3.12.3-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1092/meld-3.12.3-1.fc21
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2015-02-03 12:03:18 UTC
meld-3.12.3-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Pavel Alexeev 2015-05-19 19:25:04 UTC
Thank you very much. And very sorry for late response.