Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1177847

Summary: gnutls does not include guile bindings
Product: [Fedora] Fedora Reporter: bugs
Component: gnutlsAssignee: Nikos Mavrogiannopoulos <nmavrogi>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: bugs, nmavrogi, tmraz
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: gnutls-3.3.11-2.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-01-14 07:33:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description bugs 2014-12-30 21:15:51 UTC
The gnutls and gnutls-devel packages do not include the guile bindings for gnutls.  There also does not seem to be a subpackage containing the bindings.


$ yum install guile gnutls gnutls-devel
$ guile
scheme@(guile-user)> (use-modules (gnutls))
While compiling expression:
ERROR: no code for module (gnutls)
scheme@(guile-user)>

Comment 1 Fedora Update System 2015-01-06 10:44:15 UTC
gnutls-3.3.11-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gnutls-3.3.11-2.fc21

Comment 2 Fedora Update System 2015-01-07 01:25:59 UTC
Package gnutls-3.3.11-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnutls-3.3.11-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0271/gnutls-3.3.11-2.fc21
then log in and leave karma (feedback).

Comment 3 Nikos Mavrogiannopoulos 2015-01-07 08:27:55 UTC
Does the updated package fix your issue?

Comment 4 bugs 2015-01-07 19:23:27 UTC
No, it does not.  As far as I can tell, the new package also does not contain any Scheme files.

Comment 5 Nikos Mavrogiannopoulos 2015-01-07 21:48:01 UTC
Did you install the gnutls-guile package?

Comment 6 bugs 2015-01-07 21:56:38 UTC
No, I did not because I blindly followed the instructions above :)
I just installed gnutls-guile and it appears to do just what I want.

I do note two things, however:

- the package does not include compiled scheme files, so when first loading the gnutls module in the guile REPL the code is automatically compiled.  I think this behaviour is absent in other guile libraries, e.g the files contained in the guile-lib package (they all include the compiled version as well).
- there are compilation warnings, which may indicate missing dependencies:

~~~~~~~
scheme@(guile-user)> (use-modules (gnutls))
;;; note: auto-compilation is enabled, set GUILE_AUTO_COMPILE=0
;;;       or pass the --no-auto-compile argument to disable.
;;; compiling /usr/share/guile/site/gnutls.scm
;;; gnutls.scm:434:0: warning: possibly unbound variable `protocol/ssl3'
;;; gnutls.scm:435:0: warning: possibly unbound variable `protocol/tls1-0'
;;; gnutls.scm:436:0: warning: possibly unbound variable `protocol/tls1-1'
;;; compiled /home/rekado/.cache/guile/ccache/2.0-LE-4-2.0/usr/share/guile/site/gnutls.scm.go
scheme@(guile-user)> 
~~~~~~~

I have never used the gnutls guile bindings before, so I don't know if the warnings indicate real problems.

Comment 7 Nikos Mavrogiannopoulos 2015-01-08 09:41:41 UTC
Thanks. Ludovic Court├Ęs (the author of the guile-gnutls) mentioned that the warnings are harmless, so we can ignore them for now.

Comment 8 Fedora Update System 2015-01-14 07:33:45 UTC
gnutls-3.3.11-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.