Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1185132

Summary: F21 freeipa-client packages requires dbus-python
Product: [Fedora] Fedora Reporter: Jamie Lennox <jlennox>
Component: freeipaAssignee: IPA Maintainers <ipa-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: abokovoy, ipa-maint, jpazdziora, mkosek, nkinder, pviktori, pvoborni, rcritten, ssorce
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: freeipa-4.1.3-2.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-05 12:38:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Jamie Lennox 2015-01-23 04:09:59 UTC
This has probably never come up as dbus-python is required by almost everything however on fresh install of a F21 cloud image i yum installed freeipa-client and ran ipa-client-install to get: 

[fedora@keystone ~]$ sudo ipa-client-install
There was a problem importing one of the required Python modules. The
error was:

    No module named dbus

This was fixed by yum installing dbus-python. 


It would appear this package should be listed in the RPM requirements.

Comment 1 Martin Kosek 2015-01-23 07:45:07 UTC
Good catch. We require dbus-python in freeipa-server package, but the code that uses Python was moved to other, client exposed package.

Comment 2 Martin Kosek 2015-01-23 07:45:49 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4863

Comment 4 Rob Crittenden 2015-02-04 20:54:09 UTC
*** Bug 1189272 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2015-02-23 14:40:56 UTC
freeipa-4.1.3-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/freeipa-4.1.3-2.fc21

Comment 6 Fedora Update System 2015-02-25 13:25:30 UTC
Package freeipa-4.1.3-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freeipa-4.1.3-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2482/freeipa-4.1.3-2.fc21
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-03-05 12:38:54 UTC
freeipa-4.1.3-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.