Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1194992

Summary: Not able to get a picture.
Product: [Fedora] Fedora Reporter: dale.r.wilcox@gmail.com <dale>
Component: cheeseAssignee: Matthias Clasen <mclasen>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: amigadave, bokerones.fritos, ervindiner, hdegoede, iddnna, jreznik, kalevlember, kparal, lauryylonen66, mclasen, pschindl, robatino, satellitgo, walter.pete, wtaymans
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: clutter-gst2-2.0.14-2.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-05-21 18:44:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1043130    
Attachments:
Description Flags
The is what happens when I try to take a selfie. none

Description dale.r.wilcox@gmail.com 2015-02-21 18:46:33 UTC
Created attachment 994186 [details]
The is what happens when I try to take a selfie.

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Take picture
2. get black screen with error playing video from web can
3.

Actual results:

error playing video from web can
Expected results:
Picture

Additional info:
Laptop is a Gateway NV79 first edition i5.

Comment 1 miguel rodriguez 2015-03-05 12:14:34 UTC
I have the same problem:

(cheese:8140): cheese-WARNING **: Device '/dev/video0' is busy: gstv4l2object.c(2838): gst_v4l2_object_set_format (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin35/GstV4l2Src:video_source:
Call to S_FMT failed for YU12 @ 640x480: Dispositivo o recurso ocupado

Comment 2 D4ni3l 2015-05-08 06:07:00 UTC
I got the same problem ( Black screen when i try to take a photo):

Details: 


libGL error: Version 4 or later of flush extension not found
libGL error: failed to load driver: i915

(cheese:7227): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(cheese:7227): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

Fedora 21
Intel Pentium E281
3.17.4-301.fc21.i686

Comment 3 Wim Taymans 2015-05-19 13:25:40 UTC
probably this: https://bugzilla.gnome.org/show_bug.cgi?id=748836

Comment 4 Wim Taymans 2015-05-19 13:27:29 UTC
*** Bug 1206931 has been marked as a duplicate of this bug. ***

Comment 5 Wim Taymans 2015-05-19 13:28:21 UTC
*** Bug 1208943 has been marked as a duplicate of this bug. ***

Comment 6 Wim Taymans 2015-05-19 13:29:06 UTC
*** Bug 1217911 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2015-05-19 14:36:14 UTC
clutter-gst2-2.0.14-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/clutter-gst2-2.0.14-2.fc22

Comment 8 Fedora Blocker Bugs Application 2015-05-20 00:29:25 UTC
Proposed as a Blocker and Freeze Exception for 22-final by Fedora user pwalter using the blocker tracking app because:

 Cheese doesn't withstand basic functionality test taking a picture.

Comment 9 Fedora Update System 2015-05-20 02:52:29 UTC
Package clutter-gst2-2.0.14-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing clutter-gst2-2.0.14-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8531/clutter-gst2-2.0.14-2.fc22
then log in and leave karma (feedback).

Comment 10 Petr Schindler 2015-05-20 08:57:17 UTC
This bug occurs on F22 Final RC1. clutter-gst2 fixes it. +1 blocker from me.

Comment 11 Kamil Páral 2015-05-20 08:59:12 UTC
+1 blocker

Comment 12 Jaroslav Reznik 2015-05-20 10:41:21 UTC
+1 blocker

Comment 13 Kalev Lember 2015-05-20 10:43:13 UTC
+1 blocker

Comment 14 Kamil Páral 2015-05-20 13:27:51 UTC
Accepted as a blocker per votes above.

Comment 15 Petr Schindler 2015-05-21 10:47:52 UTC
I tested with RC2 and it works fine.

Comment 16 Fedora Update System 2015-05-21 18:44:40 UTC
clutter-gst2-2.0.14-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.