Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1208940

Summary: sundials-debuginfo-2.6.1-1 contains no sources
Product: [Fedora] Fedora Reporter: Ville Skytt√§ <ville.skytta>
Component: sundialsAssignee: Mukundan Ragavan <nonamedotc>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: anto.trande, nonamedotc
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-05-05 00:47:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 496968    

Description Ville Skyttä 2015-04-04 08:20:39 UTC
sundials-debuginfo-2.6.1-1 contains no sources. It could be due to bug 1207434 and simply a rebuild here would be enough to fix it, but it's hard to tell because even though the build tries to be verbose, it's really not -- no compiler command lines etc are shown. So this would be a good time to fix the build to be actually verbose.

Additionally, the package is not using the %cmake macro. Is there a specific reason for that? I suppose just by switching to it could fix the build verbosity issue (%cmake contains among other things -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON).

Comment 1 Mukundan Ragavan 2015-04-04 16:34:07 UTC
I will rebuild this. 

Thanks to sagitter's work, there is a going to be a revamp of the package - with individual subpackages, that is.

Comment 2 Antonio T. (sagitter) 2015-04-04 16:47:22 UTC
@Mukundan.

I wish to add some pkgconfig files to Sundials RPMs too; check this new release: https://copr-be.cloud.fedoraproject.org/results/sagitter/copasi/fedora-rawhide-x86_64/sundials-2.6.1-4.fc21/sundials-2.6.1-4.fc23.src.rpm

If you agree, i can commit now.

Comment 3 Mukundan Ragavan 2015-04-04 16:52:32 UTC
(In reply to Antonio Trande from comment #2)
> @Mukundan.
> 
> I wish to add some pkgconfig files to Sundials RPMs too; check this new
> release:
> https://copr-be.cloud.fedoraproject.org/results/sagitter/copasi/fedora-
> rawhide-x86_64/sundials-2.6.1-4.fc21/sundials-2.6.1-4.fc23.src.rpm
> 
> If you agree, i can commit now.

The pc files looks good. Please go ahead. Once built, I can verify that we have good debuginfo packages and close this bug report.

Comment 4 Antonio T. (sagitter) 2015-04-04 17:20:20 UTC
(In reply to Mukundan Ragavan from comment #3)
> 
> The pc files looks good. Please go ahead. Once built, I can verify that we
> have good debuginfo packages and close this bug report.

debuginfo is good. 
Probably, it was empty because compiler flags were not set.

Comment 5 Antonio T. (sagitter) 2015-04-04 17:20:41 UTC
(In reply to Antonio Trande from comment #4)
> (In reply to Mukundan Ragavan from comment #3)
> > 
> > The pc files looks good. Please go ahead. Once built, I can verify that we
> > have good debuginfo packages and close this bug report.
> 
> debuginfo is good. 
> Probably, it was empty because compiler flags were not set.

http://koji.fedoraproject.org/koji/buildinfo?buildID=626059

Comment 6 Antonio T. (sagitter) 2015-05-04 17:46:49 UTC
I think we can close this bug.

Comment 7 Mukundan Ragavan 2015-05-05 00:47:16 UTC
True. Closing the bug. Please reopen if the issue persists.