Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1209739

Summary: Error: kio-extras conflicts with kio_mtp-0.75-6.20131020git2063e75.fc21.x86_64
Product: [Fedora] Fedora Reporter: Sudhir Khanger <sudhir>
Component: kio-extrasAssignee: KDE SIG <kde-sig>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: kde-sig
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: kio-extras-5.2.2-5.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-04-21 19:33:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1135103    

Description Sudhir Khanger 2015-04-08 06:08:51 UTC
Description of problem:

Plasma 5 can't be installed without removing kio_mtp which will also remove Amarok and make it not-installable.

sudo yum install amarok
[sudo] password for donnie: 
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * fedora: kartolo.sby.datautama.net.id
 * updates: mirror.dhakacom.com
Resolving Dependencies
--> Running transaction check
---> Package amarok.x86_64 0:2.8.0-11.fc21 will be installed
--> Processing Dependency: amarok-utils = 2.8.0-11.fc21 for package: amarok-2.8.0-11.fc21.x86_64
--> Processing Dependency: amarok-libs(x86-64) = 2.8.0-11.fc21 for package: amarok-2.8.0-11.fc21.x86_64
--> Processing Dependency: kio_mtp for package: amarok-2.8.0-11.fc21.x86_64
--> Processing Dependency: libampache_account_login.so()(64bit) for package: amarok-2.8.0-11.fc21.x86_64
--> Processing Dependency: libamarokshared.so.1()(64bit) for package: amarok-2.8.0-11.fc21.x86_64
--> Processing Dependency: libamarokpud.so.1()(64bit) for package: amarok-2.8.0-11.fc21.x86_64
--> Processing Dependency: libamaroklib.so.1()(64bit) for package: amarok-2.8.0-11.fc21.x86_64
--> Processing Dependency: libamarokcore.so.1()(64bit) for package: amarok-2.8.0-11.fc21.x86_64
--> Processing Dependency: libamarok_service_lastfm_shared.so()(64bit) for package: amarok-2.8.0-11.fc21.x86_64
--> Processing Dependency: libamarok-transcoding.so.1()(64bit) for package: amarok-2.8.0-11.fc21.x86_64
--> Processing Dependency: libamarok-sqlcollection.so.1()(64bit) for package: amarok-2.8.0-11.fc21.x86_64
--> Running transaction check
---> Package amarok-libs.x86_64 0:2.8.0-11.fc21 will be installed
---> Package amarok-utils.x86_64 0:2.8.0-11.fc21 will be installed
---> Package kio_mtp.x86_64 0:0.75-6.20131020git2063e75.fc21 will be installed
--> Processing Conflict: kio-extras-5.2.2-4.fc21.x86_64 conflicts kio_mtp < 0.75-7
--> Finished Dependency Resolution
Error: kio-extras conflicts with kio_mtp-0.75-6.20131020git2063e75.fc21.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Update System 2015-04-08 10:18:28 UTC
kio_mtp-0.75-10.20141221gitc418634.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2015-5548/kio_mtp-0.75-10.20141221gitc418634.fc21

Comment 2 Fedora Update System 2015-04-08 12:10:36 UTC
kio-extras-5.2.2-5.fc22, kio_mtp-0.75-10.20141221gitc418634.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-5534/kio_mtp-0.75-10.20141221gitc418634.fc22,kio-extras-5.2.2-5.fc22

Comment 3 Fedora Update System 2015-04-08 18:36:18 UTC
Package kio-extras-5.2.2-5.fc22, kio_mtp-0.75-10.20141221gitc418634.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kio-extras-5.2.2-5.fc22 kio_mtp-0.75-10.20141221gitc418634.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5534/kio_mtp-0.75-10.20141221gitc418634.fc22,kio-extras-5.2.2-5.fc22
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2015-04-18 09:33:19 UTC
kio_mtp-0.75-10.20141221gitc418634.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2015-04-21 19:33:20 UTC
kio-extras-5.2.2-5.fc22, kio_mtp-0.75-10.20141221gitc418634.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.