Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1215691

Summary: Executable: plasmashell PID: 2692 Signal: Aborted
Product: [Fedora] Fedora Reporter: Petr Lautrbach <plautrba>
Component: plasma-workspaceAssignee: KDE SIG <kde-sig>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dvratil, jgrulich, kde-sig, kevin, ltinkl, rdieter, than
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: powerdevil-5.3.0-1.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-05-01 16:40:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Petr Lautrbach 2015-04-27 13:47:47 UTC
Description of problem:

plasma-workspace-5.2.2-6.fc23.x86_64, qt5-qtbase-gui-5.4.1-11.fc23.x86_64

Application: Plasma (plasmashell), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fc6177e8900 (LWP 2692))]

Thread 4 (Thread 0x7fc5f84de700 (LWP 2698)):
#0  0x00007fc60f6cb29d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fc615ab7182 in _xcb_conn_wait () at /lib64/libxcb.so.1
#2  0x00007fc615ab8d07 in xcb_wait_for_event () at /lib64/libxcb.so.1
#3  0x00007fc5fa0245e9 in QXcbEventReader::run() () at /usr/lib64/qt5/plugins/platforms/libqxcb.so
#4  0x00007fc6102dae6e in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#5  0x00007fc60e17861a in start_thread (arg=0x7fc5f84de700) at pthread_create.c:333
#6  0x00007fc60f6d6bdd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fc5f57d1700 (LWP 2710)):
#0  0x00007fc60f6cb29d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fc60ac1a3ec in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#2  0x00007fc60ac1a4fc in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#3  0x00007fc61051169b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#4  0x00007fc6104b79ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#5  0x00007fc6102d5f84 in QThread::exec() () at /lib64/libQt5Core.so.5
#6  0x00007fc61455e765 in QQmlThreadPrivate::run() () at /lib64/libQt5Qml.so.5
#7  0x00007fc6102dae6e in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#8  0x00007fc60e17861a in start_thread (arg=0x7fc5f57d1700) at pthread_create.c:333
#9  0x00007fc60f6d6bdd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fc5e4e99700 (LWP 2729)):
#0  0x00007fc60f6cb29d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fc60ac1a3ec in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#2  0x00007fc60ac1a4fc in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#3  0x00007fc61051169b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#4  0x00007fc6104b79ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#5  0x00007fc6102d5f84 in QThread::exec() () at /lib64/libQt5Core.so.5
#6  0x00007fc61455e765 in QQmlThreadPrivate::run() () at /lib64/libQt5Qml.so.5
#7  0x00007fc6102dae6e in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#8  0x00007fc60e17861a in start_thread (arg=0x7fc5e4e99700) at pthread_create.c:333
#9  0x00007fc60f6d6bdd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fc6177e8900 (LWP 2692)):
[KCrash Handler]
#5  0x00007fc60f605b28 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:55
#6  0x00007fc60f6077ba in __GI_abort () at abort.c:89
#7  0x00007fc6102c8728 in  () at /lib64/libQt5Core.so.5
#8  0x000055b9114f5116 in  ()
#9  0x000055b9114f5afa in ShellManager::loadHandlers() ()
#10 0x000055b9115171fd in ShellManager::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) ()
#11 0x00007fc6104eba51 in QObject::event(QEvent*) () at /lib64/libQt5Core.so.5
#12 0x00007fc611a4e7cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#13 0x00007fc611a53e70 in QApplication::notify(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#14 0x00007fc6104ba18b in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /lib64/libQt5Core.so.5
#15 0x00007fc6104bc2c7 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /lib64/libQt5Core.so.5
#16 0x00007fc610511273 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () at /lib64/libQt5Core.so.5
#17 0x00007fc60ac1a0ba in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#18 0x00007fc60ac1a450 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#19 0x00007fc60ac1a4fc in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#20 0x00007fc61051167f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#21 0x00007fc6104b79ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#22 0x00007fc6104bf53c in QCoreApplication::exec() () at /lib64/libQt5Core.so.5
#23 0x000055b9114c300c in main ()


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Petr Lautrbach 2015-04-27 14:35:22 UTC
'dnf install plasma-desktop' fixed this problem. The segfault should not occur or plasma-desktop should be a requirement for plasma-workspace

Comment 2 Rex Dieter 2015-04-27 16:20:33 UTC
The dependency is the other way: -desktop Requires: -workspace

Comment 3 Daniel Vrátil 2015-04-28 08:35:51 UTC
I could swear that we already fixed that, but that was probably only in comps...

Well, strictly speaking plasma-workspace does not depend on plasma-desktop - plasma-desktop only provides *a* Plasma shell for plasma-workspace. So here's an idea:

What about plasma-desktop providing plasmashell(desktop), and plasma-workspace requiring plasmashell?

I think this models very closely what upstream has in mind, i.e. providing alternative shells (plasma-desktop, plasma-mobile, plasma-touch, etc) for plasma-workspace.

But I'm also fine with keeping it simple for now and go for -workspace requiring -desktop, since we don't have any alternative shells at this moment anyway.

Comment 4 Rex Dieter 2015-04-28 19:28:49 UTC
I was thinking along those lines too, I just dislike circular dependencies (though if we protect it with bootstrap macros, the pain of that should be minimized)

Comment 5 Fedora Update System 2015-04-30 15:21:35 UTC
powerdevil-5.3.0-1.fc22, kmenuedit-5.3.0-1.fc22, kdeplasma-addons-5.3.0-1.fc22, plasma-oxygen-5.3.0-1.fc22, libksysguard-5.3.0-1.fc22, kwrited-5.3.0-1.fc22, kf5-kfilemetadata-5.9.0-1.fc22, khelpcenter-5.3.0-1.fc22, khotkeys-5.3.0-1.fc22, sddm-kcm-5.3.0-1.fc22, polkit-kde-5.3.0-1.fc22, plasma-workspace-wallpapers-5.3.0-1.fc22, ksysguard-5.3.0-1.fc22, kio-extras-5.3.0-1.fc22, kdecoration-5.3.0-1.fc22, kf5-baloo-5.9.0-1.fc22, kde-cli-tools-5.3.0-1.fc22, plasma-breeze-5.3.0-1.fc22, kscreen-5.3.0-1.fc22, ksshaskpass-5.3.0-1.fc22, plasma-sdk-5.3.0-1.fc22, kf5-kwayland-5.3.0-1.fc22, kinfocenter-5.3.0-1.fc22, plasma-systemsettings-5.3.0-1.fc22, plasma-nm-5.3.0-1.fc22, plasma-milou-5.3.0-1.fc22, oxygen-fonts-5.3.0-1.fc22, kwin-5.3.0-2.fc22, plasma-desktop-5.3.0-3.fc22, plasma-workspace-5.3.0-3.fc22, libkscreen-qt5-5.3.0-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-7070/oxygen-fonts-5.3.0-1.fc22,powerdevil-5.3.0-1.fc22,plasma-workspace-5.3.0-3.fc22,plasma-desktop-5.3.0-3.fc22,kio-extras-5.3.0-1.fc22,kmenuedit-5.3.0-1.fc22,kdecoration-5.3.0-1.fc22,kdeplasma-addons-5.3.0-1.fc22,kf5-baloo-5.9.0-1.fc22,plasma-oxygen-5.3.0-1.fc22,kde-cli-tools-5.3.0-1.fc22,libksysguard-5.3.0-1.fc22,kwin-5.3.0-2.fc22,kwrited-5.3.0-1.fc22,plasma-breeze-5.3.0-1.fc22,kf5-kfilemetadata-5.9.0-1.fc22,kscreen-5.3.0-1.fc22,khelpcenter-5.3.0-1.fc22,ksshaskpass-5.3.0-1.fc22,khotkeys-5.3.0-1.fc22,plasma-sdk-5.3.0-1.fc22,sddm-kcm-5.3.0-1.fc22,kf5-kwayland-5.3.0-1.fc22,libkscreen-qt5-5.3.0-2.fc22,kinfocenter-5.3.0-1.fc22,polkit-kde-5.3.0-1.fc22,plasma-systemsettings-5.3.0-1.fc22,plasma-workspace-wallpapers-5.3.0-1.fc22,plasma-nm-5.3.0-1.fc22,ksysguard-5.3.0-1.fc22,plasma-milou-5.3.0-1.fc22

Comment 6 Fedora Update System 2015-05-01 16:40:30 UTC
powerdevil-5.3.0-1.fc22, kmenuedit-5.3.0-1.fc22, kdeplasma-addons-5.3.0-1.fc22, plasma-oxygen-5.3.0-1.fc22, libksysguard-5.3.0-1.fc22, kwrited-5.3.0-1.fc22, kf5-kfilemetadata-5.9.0-1.fc22, khelpcenter-5.3.0-1.fc22, khotkeys-5.3.0-1.fc22, sddm-kcm-5.3.0-1.fc22, polkit-kde-5.3.0-1.fc22, plasma-workspace-wallpapers-5.3.0-1.fc22, ksysguard-5.3.0-1.fc22, kio-extras-5.3.0-1.fc22, kdecoration-5.3.0-1.fc22, kf5-baloo-5.9.0-1.fc22, kde-cli-tools-5.3.0-1.fc22, plasma-breeze-5.3.0-1.fc22, kscreen-5.3.0-1.fc22, ksshaskpass-5.3.0-1.fc22, plasma-sdk-5.3.0-1.fc22, kf5-kwayland-5.3.0-1.fc22, kinfocenter-5.3.0-1.fc22, plasma-systemsettings-5.3.0-1.fc22, plasma-nm-5.3.0-1.fc22, plasma-milou-5.3.0-1.fc22, oxygen-fonts-5.3.0-1.fc22, kwin-5.3.0-2.fc22, plasma-desktop-5.3.0-3.fc22, plasma-workspace-5.3.0-3.fc22, libkscreen-qt5-5.3.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.