Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1216098

Summary: RFE: Option to customize the bodhi client timeout
Product: [Fedora] Fedora Reporter: Michael Schwendt <bugs.michael>
Component: fedora-easy-karmaAssignee: Till Maas <opensource>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: opensource, samuel-rhbugs
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-01 17:02:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Michael Schwendt 2015-04-28 13:32:43 UTC
For some time, fedora-easy-karma has been failing to retrieve the list of packages from bodhi due to the default timeout being too short. I've looked into ways how to increase that timeout, and there doesn't seem to be a way to configure it via an option. However, modifying fedora-easy-karma and initializing the BodhiClient instance with 

        bc.timeout = 300

is a successful work-around.

Comment 1 Fedora Update System 2015-05-08 20:12:59 UTC
fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc21

Comment 2 Fedora Update System 2015-05-08 20:13:07 UTC
fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc22

Comment 3 Fedora Update System 2015-05-08 20:13:14 UTC
fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc20

Comment 4 Fedora Update System 2015-05-10 23:33:39 UTC
Package fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7869/fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-06-01 17:02:46 UTC
fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2015-06-01 17:04:13 UTC
fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2015-06-01 17:04:44 UTC
fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.