Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1221559

Summary: Mono 4
Product: [Fedora] Fedora Reporter: Jan Kurik <jkurik>
Component: Changes TrackingAssignee: Jan Kurik <jkurik>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: claudiorodrigo, hinop, jorti, jreznik, moez.roy, pokorra.mailinglists
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: ChangeAcceptedF23, SystemWideChange
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-29 11:25:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1187311, 1222926, 1222937, 1222945, 1222980, 1222982, 1222984, 1222992, 1222996, 1223059, 1223409, 1223449, 1223464, 1225201, 1232684    
Bug Blocks: 1159091, 1166897, 1166916, 1222662, 1223442, 1223455, 1244899    

Description Jan Kurik 2015-05-14 11:14:24 UTC
This is a tracking bug for Change: Mono 4
For more details, see: https://fedoraproject.org//wiki/Changes/Mono_4

Update the Mono stack in Fedora from 2.10 to 4.*

Comment 1 Claudio Rodrigo Pereyra DIaz 2015-05-28 11:10:16 UTC
*** Bug 1089278 has been marked as a duplicate of this bug. ***

Comment 2 Jan Kurik 2015-07-14 14:02:45 UTC
This message is a reminder that Fedora 23 Change Checkpoint: Completion deadline (testable) is on 2015-07-28 [1].

At this point, all accepted Changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Completion deadline.

This bug should be set at least to the MODIFIED state to indicate that it achieved completeness. Status will be provided to FESCo right after the deadline. If, for any reasons, your Change is not in required state, let me know and we will try to find solution. For Changes you decide to cancel/move to the next release, please use the NEW status and set needinfo on me and it will be acted upon. 

In case of any questions, don't hesitate to ask Wrangler (jkurik). Thank you.

[1] https://fedoraproject.org/wiki/Releases/23/Schedule

Comment 3 Claudio Rodrigo Pereyra DIaz 2015-07-29 17:09:41 UTC
Mono 4 Change is almost complete.

New packages needed for build actual packages in Fedora (nunit and nuget) was packaged.
Other new packages are desirable but not required, and could be packaged later.

Only shogun package fail to build, but is a problem that involve more than mono.
Octave and swing cause problem to build to. And is not required for any other mono package.

I think the goal is done. We have Mono 4 ready for use on Fedora

Comment 4 hinop 2015-08-30 20:27:46 UTC
Will Fedora 23 already have Mono 4.3 or just 4.0/1/2?

Comment 5 Timotheus Pokorra 2015-08-31 04:25:30 UTC
You can check for the state of the releases at the Xamarin release blog: https://releases.xamarin.com/, see only stable releases at https://releases.xamarin.com/category/stable/

There is currently a Beta release for 4.0.4.1, and an Alpha release for 4.2.0.179

We will only put stable releases of Mono into Fedora 23, which is currently 4.0.3.20

Another question is: should we stay with 4.0.x for Fedora 23 for the whole lifetime of Fedora 23, and upgrade to 4.2.x for Fedora 24? Perhaps something to discuss in the mono SIG...

Comment 6 hinop 2015-08-31 16:43:29 UTC
I'm not aware of the technical background. Why don't use the latest Mono release from http://www.mono-project.com/docs/about-mono/releases/ (4.3)?

Comment 7 Timotheus Pokorra 2015-08-31 18:38:17 UTC
On that page http://www.mono-project.com/docs/about-mono/releases/ it only mentions 4.0.3, there is no 4.3. We are indeed using 4.0.3 for Fedora 23.

Comment 8 hinop 2015-08-31 18:40:26 UTC
Oh, wtf, totally my mistake.

Comment 9 Jan Kurik 2015-09-01 14:54:21 UTC
This message is a reminder that Fedora 23 Change Checkpoint: 100% Code Complete Deadline is on 2015-Sep-08 [1].

Expected bug state is ON_QA - Change has to be code complete and is possible to test it in the Beta release.

Status will be provided to FESCo right after the deadline. If, for any reasons, your Change is not in required state, let me know and we will try to find solution.  It's important milestone as contingency plan may be put into effect if the Change that miss this deadline.

In case of any questions, don't hesitate to ask Wrangler (jkurik). Thank you.

[1] https://fedoraproject.org/wiki/Releases/23/Schedule