Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1222604

Summary: SELinux is preventing gnome-keyring-d from 'write' accesses on the directory /run/user/1004.
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: berend.de.schouwer, dominick.grift, dwalsh, lvrabec, mgrepl, plautrba
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:9fce1d91596c99afc28b5127101d696b399b4780cc84e54f0dd04ebef60b65b5
Fixed In Version: selinux-policy-3.13.1-128.2.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-27 22:33:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Kamil Páral 2015-05-18 15:28:49 UTC
Description of problem:
This shows up after I change my user password using gnome-control-center.
SELinux is preventing gnome-keyring-d from 'write' accesses on the directory /run/user/1004.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gnome-keyring-d should be allowed write access on the 1004 directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gnome-keyring-d /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:user_tmp_t:s0
Target Objects                /run/user/1004 [ dir ]
Source                        gnome-keyring-d
Source Path                   gnome-keyring-d
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-122.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.0.2-300.fc22.x86_64 #1 SMP Thu
                              May 7 16:05:02 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-05-18 17:27:40 CEST
Last Seen                     2015-05-18 17:27:40 CEST
Local ID                      1317a0c7-7d1d-4eb1-9387-ea761031f81b

Raw Audit Messages
type=AVC msg=audit(1431962860.6:548): avc:  denied  { write } for  pid=3411 comm="gnome-keyring-d" name="/" dev="tmpfs" ino=37232 scontext=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:user_tmp_t:s0 tclass=dir permissive=0


Hash: gnome-keyring-d,passwd_t,user_tmp_t,dir,write

Version-Release number of selected component:
selinux-policy-3.13.1-122.fc22.noarch

Additional info:
reporter:       libreport-2.5.1
hashmarkername: setroubleshoot
kernel:         4.0.2-300.fc22.x86_64
type:           libreport

Potential duplicate: bug 1160397

Comment 1 Berend De Schouwer 2015-05-31 13:33:09 UTC
Description of problem:
Changed my user password after installing Fedora 22 and booting a fresh install.

I had used an easy password during installation (because of another problem), and wanted to make it harder.






Version-Release number of selected component:
selinux-policy-3.13.1-122.fc22.noarch

Additional info:
reporter:       libreport-2.5.1
hashmarkername: setroubleshoot
kernel:         4.0.4-301.fc22.x86_64
type:           libreport

Comment 2 Miroslav Grepl 2015-06-16 11:17:30 UTC
Author: Miroslav Grepl <mgrepl>
Date:   Tue Jun 16 13:15:09 2015 +0200

    Allow gnome-keyring executed by passwd to access /run/user/UID/keyring to change a password. BZ(1222604)

Comment 3 Fedora Update System 2015-06-19 07:51:18 UTC
selinux-policy-3.13.1-128.2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/selinux-policy-3.13.1-128.2.fc22

Comment 4 Fedora Update System 2015-06-21 00:34:02 UTC
Package selinux-policy-3.13.1-128.2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.13.1-128.2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10299/selinux-policy-3.13.1-128.2.fc22
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-06-27 22:33:39 UTC
selinux-policy-3.13.1-128.2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.