Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1234358

Summary: /var/log/messages rotated but processes still writing to old file
Product: [Fedora] Fedora Reporter: Jonathan Wakely <jwakely>
Component: rsyslogAssignee: Tomas Heinrich <theinric>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: jlieskov, lkundrak, mah.darade, pvrabec, theinric
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-28 06:54:21 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Jonathan Wakely 2015-06-22 12:25:41 UTC
Description of problem:

I booted my machine up this morning and several log files seem to have rolled, however processes are still writing to the old version of the file. (Similar to Bug 917560).

I have an empty /var/log/messages, but lots of info in /var/log/messages-20150622, which lsof shows is still in use:

# lsof | fgrep messages
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
      Output information may be incomplete.
rsyslogd    935          root    3w      REG              253,0  58066589    1981473 /var/log/messages-20150622
in:imjour   935   964    root    3w      REG              253,0  58066589    1981473 /var/log/messages-20150622
rs:main     935   965    root    3w      REG              253,0  58066589    1981473 /var/log/messages-20150622

Shouldn't those processes have been sent a SIGHUP when the log rolled, so they write to /var/log/messages instead?


Version-Release number of selected component (if applicable):

logrotate-3.8.8-1.fc22.x86_64
rsyslog-8.8.0-2.fc22.x86_64

Comment 1 Stefan Becker 2015-06-28 06:54:21 UTC

*** This bug has been marked as a duplicate of bug 1224972 ***