Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1240591

Summary: Clipboard is cleared when LO is closed
Product: [Fedora] Fedora Reporter: romu <r>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 23CC: caolanm, dtardon, erack, jgrulich, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: libreoffice-5.0.4.2-4.fc23 libreoffice-5.0.5.2-1.fc23 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-02-15 02:51:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description romu 2015-07-07 10:05:12 UTC
Description of problem:
Data in the clipboard coming from LO are lost once LO is closed.

Version-Release number of selected component (if applicable):
4.4.x

How reproducible:
100%

Steps to Reproduce:
1. Open a document with LO Writer
2. Open gEdit
3. Copy some text in LO writer
4. Close LO
5. Switch to gEdit and try to paste

Actual results:
The text can't be paste because the clipboard has been cleared.

Expected results:
The text stays in the clipboard for future use.

Additional info:
It may be fair to have a confirmation dialog to keep the data in clipboard or not when closing LO.

Comment 1 Caolan McNamara 2016-01-18 09:27:58 UTC
Our current gtk2 impl doesn't use gtk for c-n-p, but uses the old direct X11 calls. The new gtk3 one does use the gtk apis, so at least in theory if we can find the right place to call gtk_clipboard_store somewhere during shutdown we should be able to finally support this.

Comment 2 Caolan McNamara 2016-01-21 12:03:52 UTC
can't do anything about f22. But for f23 onwards with libreoffice-gtk3 installed we can finally support this

Comment 3 Fedora Update System 2016-02-08 12:30:52 UTC
libreoffice-5.0.5.1-7.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2fca765923

Comment 4 Fedora Update System 2016-02-09 22:27:26 UTC
libreoffice-5.0.5.1-7.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2fca765923

Comment 5 Fedora Update System 2016-02-15 02:51:45 UTC
libreoffice-5.0.5.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.