Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1265707

Summary: Wayland: `sudo gvim` can't access the display
Product: [Fedora] Fedora Reporter: Stephen Gallagher <sgallagh>
Component: waylandAssignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 23CC: ajax, fedora, mclasen
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-31 22:48:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1277927    

Description Stephen Gallagher 2015-09-23 13:57:32 UTC
Description of problem:
Attempting to run `sudo gvim /path/to/file` returns:
No protocol specified
E233: cannot open displayE852: The child process failed to start the GUI
No protocol specified

And then falls back to the text vim interface, rather than launching the graphical version.


Version-Release number of selected component (if applicable):
wayland-1.8.93-1.fc23.x86_64
sudo-1.8.14p3-1.fc23.x86_64
vim-X11-7.4.827-1.fc23.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Install the vim-X11 package
2. Run `sudo gvim /path/to/file`

Actual results:
No protocol specified
E233: cannot open displayE852: The child process failed to start the GUI
No protocol specified

And then falls back to the text vim interface.

Expected results:
The graphical version of gVIM should be launched.

Additional info:
This is a problem only when running under Wayland. It works fine under X11.

I'm not sure what the correct component is, so I'm going with 'wayland'. Please feel free to reassign it as appropriate. I tested this with both gnome-terminal and xterm.

Comment 1 Christian Stadelmann 2016-07-21 15:53:52 UTC
Duplicate of bug #1274451. Wayland doesn't allow any graphical apps to be run as root.

Comment 2 Matthias Clasen 2016-08-31 22:48:25 UTC

*** This bug has been marked as a duplicate of bug 1274451 ***