Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1266801

Summary: Savetrees has dependency on titlesec.sty but not in SPEC
Product: [Fedora] Fedora Reporter: Dennis Chen <barracks510>
Component: texliveAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 22CC: novyjindrich, tcallawa, than
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: texlive-2014-14.20140525_r34255.fc23 texlive-2014-11.20140525_r34255.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-10-04 19:14:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Dennis Chen 2015-09-28 00:53:07 UTC
Description of problem:
Savetrees subpackage has dependency on tex(titlesec.sty) which is not specified in the SPEC file.

Version-Release number of selected component (if applicable):
2014-8.20140525_r34255.fc22

How reproducible:
Very

Steps to Reproduce:
1. Install texlive through dnf.
2. Install texlive-savetrees through dnf.
3. Use the savetrees package in a proper latex document.

Actual results:
pdflatex and latex complain of missing titlesec.sty

Expected results:
Complete compilation without error.

Comment 1 Tom "spot" Callaway 2015-09-28 13:26:26 UTC
I've committed the fix to rawhide. Since this is a relatively minor dependency issue (and easy enough to work around), I'm going to wait on pushing it as an update for the released trees (21-23).

Comment 2 Fedora Update System 2015-10-02 02:53:57 UTC
texlive-2014-11.20140525_r34255.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-583aa38cf3

Comment 3 Fedora Update System 2015-10-02 02:53:57 UTC
texlive-2014-14.20140525_r34255.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-5ab93deea4

Comment 4 Fedora Update System 2015-10-04 01:36:36 UTC
texlive-2014-11.20140525_r34255.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update texlive'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-583aa38cf3

Comment 5 Fedora Update System 2015-10-04 01:52:41 UTC
texlive-2014-14.20140525_r34255.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update texlive'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-5ab93deea4

Comment 6 Fedora Update System 2015-10-04 19:14:14 UTC
texlive-2014-14.20140525_r34255.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2015-10-13 17:02:30 UTC
texlive-2014-11.20140525_r34255.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.