Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1270568

Summary: smb fails to start
Product: [Fedora] Fedora Reporter: Nerijus Baliūnas <nerijus>
Component: sambaAssignee: Guenther Deschner <gdeschner>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: abokovoy, asn, awilliam, gdeschner, jlayton, lmohanty, madam, sbose, ssorce
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: RejectedFreezeException
Fixed In Version: samba-4.3.0-3.fc23 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-01 02:39:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Nerijus Baliūnas 2015-10-11 10:44:32 UTC
After F22->23 upgrade smb fails to start:
# systemctl start smb
Job for smb.service failed because the control process exited with error code. See "systemctl status smb.service" and "journalctl -xe" for details.

# systemctl status smb
● smb.service - Samba SMB Daemon
   Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sk 2015-10-11 13:32:14 EEST; 4s ago
  Process: 2448 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=1/FAILURE)
 Main PID: 2448 (code=exited, status=1/FAILURE)

Spa 11 13:32:14 nerijus systemd[1]: Starting Samba SMB Daemon...
Spa 11 13:32:14 nerijus systemd[1]: smb.service: Main process exited, code=exited, status=1/FAILURE
Spa 11 13:32:14 nerijus systemd[1]: Failed to start Samba SMB Daemon.
Spa 11 13:32:14 nerijus systemd[1]: smb.service: Unit entered failed state.
Spa 11 13:32:14 nerijus systemd[1]: smb.service: Failed with result 'exit-code'.

Only after upgrading to samba-4.3.0-1.fc23.x86_64.rpm I got /var/log/samba/log. file, which said:
[2015/10/11 13:32:50.806509,  0] ../lib/util/util.c:285(directory_create_or_exist_strict)
  invalid permissions on directory '/var/lib/samba/msg': has 0700 should be 0755

Changing /var/lib/samba/msg permissions or deleting /var/lib/samba/msg directory allowed smb to start.

Comment 2 Fedora Update System 2015-10-12 14:00:44 UTC
samba-4.3.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ff4a6c72c7

Comment 3 Fedora Update System 2015-10-12 17:42:29 UTC
samba-4.3.0-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-40a82bc06a

Comment 4 Fedora Update System 2015-10-12 23:50:36 UTC
samba-4.3.0-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update samba'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-40a82bc06a

Comment 5 Fedora Update System 2015-10-12 23:50:46 UTC
samba-4.3.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update samba'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ff4a6c72c7

Comment 6 Fedora Blocker Bugs Application 2015-10-14 07:03:58 UTC
Proposed as a Freeze Exception for 23-final by Fedora user pwalter using the blocker tracking app because:

 Would be good to ship with working smb.service

Comment 7 Adam Williamson 2015-10-15 21:49:01 UTC
Discussed at 2015-10-15 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-15/f23-blocker-review.2015-10-15-20.11.log.txt . We tested, and it appears this is an upgrade-only issue: on a clean install of F23, the samba from current stable (0.1.rc4) starts up fine. Upgrades always use the repos anyway, so there's no need for a freeze exception to fix the upgrade case, hence this is rejected (the update can go out as a 0-day and upgrades on release day will work).

Comment 8 Fedora Update System 2015-11-01 02:39:28 UTC
samba-4.3.0-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.