Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1270600

Summary: fedora-easy-karma can not execute without yum or python2-dnf (missing dependency)
Product: [Fedora] Fedora Reporter: Raphael Groner <projects.rg>
Component: fedora-easy-karmaAssignee: Till Maas <opensource>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 24CC: fvillavi, h.reindl, louzaoh, mhroncok, opensource, watanabe.yu
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: fedora-easy-karma-0-0.28.20150921gitc932687a.fc24 fedora-easy-karma-0-0.28.20150921gitc932687a.fc23 fedora-easy-karma-0-0.34.20171019gitbc16e916.fc25 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-09 04:56:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Raphael Groner 2015-10-11 17:57:14 UTC
Description of problem:
$ fedora-easy-karma --help
Traceback (most recent call last):
  File "/bin/fedora-easy-karma", line 47, in <module>
    import yum
ImportError: No module named yum


Version-Release number of selected component (if applicable):
fedora-easy-karma-0-0.26.20150921gitc932687a.fc23.noarch
dnf-1.1.2-4.fc23.noarch
yum-3.4.3-507.fc23.noarch

How reproducible:
yes

Steps to Reproduce:
1. $ fedora-easy-karma --help
2.
3.

Actual results:
fails with error above

Expected results:
works

Additional info:
fedora-easy-karma should depend on yum or be ported to use new dnf

Comment 1 Till Maas 2015-10-28 20:17:50 UTC
sorry for the late reply, it is ported to dnf but since F23 switched to python3 by default you need to install python-dnf to make it use dnf. Fedora-easy-karma cannot yet use python3 because of pkgs it depends on. Also it is not possible for it to say that it can use either yum or dnf, therefore the dep is currently missing. I will probably just add a python-dnf dependency eventually.

Comment 2 Raphael Groner 2015-10-29 14:40:40 UTC
It's useful to depend on python-dnf in Fedora 23, as yum does not get installed by default.

Comment 3 Till Maas 2015-12-15 09:58:00 UTC
*** Bug 1290984 has been marked as a duplicate of this bug. ***

Comment 4 Raphael Groner 2016-03-24 15:32:36 UTC
Any news here? I'm still able to reproduce in Fedora 23.
fedora-easy-karma-0-0.26.20150921gitc932687a.fc23.noarch
dnf-1.1.7-2.fc23.noarch

Can you add a weak dependency to python2-dnf, as you suggest in comment #1?

Comment 5 Till Maas 2016-03-24 17:04:33 UTC
Thank you for the reminder, there will be an update shortly.

Comment 6 Fedora Update System 2016-03-24 17:08:37 UTC
fedora-easy-karma-0-0.28.20150921gitc932687a.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3495b9a120

Comment 7 Fedora Update System 2016-03-24 17:08:43 UTC
fedora-easy-karma-0-0.28.20150921gitc932687a.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a1ad1a4378

Comment 8 Harald Reindl 2016-03-24 19:53:59 UTC
python2-dnf is *not* needed

fix fedora-easy-karma to work with dnf but don't pull useless python2 stuff even as weak-dependency - see bodhi comment written with fedora-easy-karma *after* remve all that oython2 stuff again which was pulled by "dnf update package.rpm" after download from koji

Comment 9 Till Maas 2016-03-25 08:47:35 UTC
*** Bug 1302919 has been marked as a duplicate of this bug. ***

Comment 10 Till Maas 2016-03-25 08:51:08 UTC
python2-dnf or yum is needed right now. AFAIK I cannot use rich dependencies to specify this. Porting fedora-easy-karma to Python3 requires its dependencies to be available for python3, but fedora-packager is currently not available for python3, see bug 1024796.

Comment 11 Fedora Update System 2016-03-25 20:27:58 UTC
fedora-easy-karma-0-0.28.20150921gitc932687a.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3495b9a120

Comment 12 Fedora Update System 2016-03-26 15:20:00 UTC
fedora-easy-karma-0-0.28.20150921gitc932687a.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a1ad1a4378

Comment 13 Raphael Groner 2016-04-20 08:57:26 UTC
Why don't you push to stable?

fc24, karma +15, in testing a month ago
fc23, karma +20, in testing 24 days

Comment 14 Christian Stadelmann 2016-04-20 09:19:58 UTC
Raphael Groner: Because this update doesn't fix the issue. Instead it might break fedora-easy-karma because dependencies are broken.

Comment 15 Raphael Groner 2016-04-20 09:50:30 UTC
Christian Stadelmann: I don't ask you but the maintainer of fedora-easy-karma.

Comment 16 Till Maas 2016-04-21 10:45:42 UTC
Christian: Could you elaborate on the broken dependencies?
Raphael: Since f-e-k requires enabling updates-testing to be useful (afaik), I do not see much extra value in pushing it to stable. Also I am still hoping that I will be able to use rich dependencies eventually, but this still needs some fixes in the infrastructure.

Comment 17 Christian Stadelmann 2016-04-21 22:59:47 UTC
Till: It misses a dependency to yum. This last update didn't include a "fix", problem still persists. f-e-k breaks at runtime failing to load dependencies.

$ fedora-easy-karma 
Traceback (most recent call last):
  File "/usr/bin/fedora-easy-karma", line 47, in <module>
    import yum
ImportError: No module named yum

I'm running fedora-easy-karma-0-0.28.20150921gitc932687a.fc24.noarch

Please don't push this update to stable. Please have a look at https://bodhi.fedoraproject.org/updates/FEDORA-2016-a1ad1a4378 and https://bodhi.fedoraproject.org/updates/FEDORA-2016-3495b9a120, especially to comments of @hreindl.

f-e-k must depend on some yum or dnf package, but it doesn't. This is why it breaks.

Comment 18 Raphael Groner 2016-04-22 09:27:47 UTC
I still fail to see the problem?!

If you insist to keep with yum, do:

dnf remove -y python2-dnf && dnf install -y yum

f-e-k prefers dnf over yum if available. To try in first step with dnf is in common sense due to dnf is now the default package manager. Works for me!

Comment 19 Christian Stadelmann 2016-04-22 10:26:57 UTC
Then f-e-k MUST depend on either one of these. Since it doesn't run without either of these, it is still a dependency issue caused by a packaging bug.

dnf is using python3 by default, so you can't expect anyone to have the python2-dnf package installed. yum is history anyway.

I tested on both vanilla Fedora 23 (ISO number 10) and vanilla 24 (Alpha 7). On both it fails with the same traceback.

Comment 20 Harald Reindl 2016-04-22 10:30:31 UTC
the just require yum and you are done

yum is anyways needed for serious testers because 

* dnf don't work most times with downloads (dnf update *.rpm)
* nothing is able to replace yum-utils

so don't pull me additional junk not needed all the time while yum is enough

Comment 21 Raphael Groner 2016-04-22 11:03:53 UTC
This bug is closed, please notice. If you still think there's an issue, open a new bug. But do not spam me with your misunderstanding. We tried to explain, you do not understand.

Comment 22 Harald Reindl 2016-04-22 11:08:09 UTC
@Raphael Groner: who do you think you are?
Removed CC|h.reindl

* that you closed the bug means nothing
* it's not in stable updates
* it's not there for good reasons
* pull me useless new deps is not a solution
* if it ain't broken don't fix it

Comment 23 Yu Watanabe 2016-05-10 09:15:36 UTC
As many people reports, fedora-easy-karma-0-0.28.20150921gitc932687a has a dependency issue.
Now, I found that fedora-easy-karma-0-0.29.20160408gitb5cdbc7f.fc25 has 'correct' dependencies. (Of course, it brings new deps that Harald do not want.) I've tried to build 0.29 for F24, it also works as expected.

Comment 24 Till Maas 2016-05-10 20:52:44 UTC
(In reply to Yu Watanabe from comment #23)
> As many people reports, fedora-easy-karma-0-0.28.20150921gitc932687a has a
> dependency issue.
> Now, I found that fedora-easy-karma-0-0.29.20160408gitb5cdbc7f.fc25 has
> 'correct' dependencies. (Of course, it brings new deps that Harald do not
> want.) I've tried to build 0.29 for F24, it also works as expected.


I do not follow, there is only a 0.29 build for EPEL, because there was no change that affects Fedora in 0.29. 0.28 should already have the recommended dependency.

Comment 25 Yu Watanabe 2016-05-11 03:22:39 UTC
Sorry, I had a mistake. I use 0.28.fc25, not 0.29.

For fedora 23 or 24,
===
dnf --releasever=24 --installroot /tmp/hoge install fedora-easy-karma
===
does not bring python2-dnf. The recommendation of python2-dnf is ignored. The version of f-e-k is 0.28.

For rawhide,
===
dnf --disablerepo=* --enablerepo=rawhide --installroot /tmp/hoge install fedora-easy-karma
===
This brings python2-dnf, and the recommendation seems to work. The version is also 0.28.

Also, as written in my previous comment, my local build of 0.29 for fedora 23 and 24 can bring python2-dnf correctly.

I guess that the wrong recommended dependency for 0.28.fc23 (or fc24) is caused by the build system, not by f-e-k spec. What do you think about?

Comment 26 Miro Hrončok 2016-07-28 12:33:18 UTC
I can confirm this for Fedora 24, installing python2-dnf fixes the problem.

Comment 27 Till Maas 2016-08-07 14:49:00 UTC

*** This bug has been marked as a duplicate of bug 1329629 ***

Comment 28 Fedora Update System 2016-09-18 02:20:59 UTC
fedora-easy-karma-0-0.28.20150921gitc932687a.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 29 Miro Hrončok 2016-09-18 09:20:10 UTC
The mentioned update does nto fix this problem, according to the comments.

Comment 30 Till Maas 2016-09-19 19:54:38 UTC
(In reply to Miro Hrončok from comment #29)
> The mentioned update does nto fix this problem, according to the comments.

Please see: https://bugzilla.redhat.com/show_bug.cgi?id=1329629#c11 - the update should now fix this (good enough).

Comment 31 Fedora Update System 2016-09-21 20:23:18 UTC
fedora-easy-karma-0-0.28.20150921gitc932687a.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 32 Till Maas 2017-09-30 10:59:34 UTC
*** Bug 1497388 has been marked as a duplicate of this bug. ***

Comment 33 Fedora Update System 2017-09-30 11:36:05 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1a378bed07

Comment 34 Fedora Update System 2017-09-30 11:36:20 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-e2634c3757

Comment 35 Fedora Update System 2017-09-30 11:36:37 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-35e7efea31

Comment 36 Fedora Update System 2017-09-30 11:36:52 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f6271d2b93

Comment 37 Fedora Update System 2017-09-30 11:37:08 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-da6c16bf49

Comment 38 Harald Reindl 2017-09-30 11:48:57 UTC
> Porting fedora-easy-karma to Python3 requires its 
> dependencies to be available for python3, but 
> fedora-packager is currently not available for python3

so what about the clowns enfored the deprecation of yum prting it and why did they not port it before punish everybody using "yum-deprecated" over 4 releases with warnings making it unuseable for cronjobs?

Comment 39 Till Maas 2017-09-30 12:03:25 UTC
(In reply to Harald Reindl from comment #38)

> so what about the clowns enfored the deprecation of yum prting it and why
> did they not port it before punish everybody using "yum-deprecated" over 4
> releases with warnings making it unuseable for cronjobs?

Please watch your language.

Comment 40 Harald Reindl 2017-09-30 12:07:39 UTC
my language is way too nice when we talk about people which replace working things but don't finish their work over years while explain others "you need to cope with changes" 

the state in which DNF was as it replaced official YUm in Fedora 22 was a bad joke and now when it start's to get usable Fedora's own infrastructure packages can't still cope with it and need python2/yum - are you kidding me?

and for the record: it did NOT ask for replace YUM to start with, but when people decide to do so *do it proper or leave your fingers from the perfectly working distribution*

Comment 41 Till Maas 2017-09-30 14:05:33 UTC
(In reply to Harald Reindl from comment #40)
> my language is way too nice

Your language is never "too nice". There is never a reason of disrespectful language in the Fedora project. Please follow the Fedora code of conduct:
https://getfedora.org/code-of-conduct

Comment 42 Raphael Groner 2017-09-30 16:14:46 UTC
Please, could you move your (personal) discussion to somewhere else? I don't see why it matters directly to here.
This bug is fixed and Harald created another one (bug #1497388) for his new issue. Folks, consider to continue there.

Comment 43 Fedora Update System 2017-10-01 23:48:45 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-e2634c3757

Comment 44 Fedora Update System 2017-10-01 23:49:37 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-35e7efea31

Comment 45 Fedora Update System 2017-10-01 23:55:13 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1a378bed07

Comment 46 Fedora Update System 2017-10-02 00:55:50 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-da6c16bf49

Comment 47 Fedora Update System 2017-10-02 00:56:42 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f6271d2b93

Comment 48 Fedora Update System 2017-10-08 23:55:31 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 49 Fedora Update System 2017-10-09 01:20:18 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 50 Fedora Update System 2017-10-19 21:47:20 UTC
fedora-easy-karma-0-0.34.20171019gitbc16e916.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d136b70561

Comment 51 Fedora Update System 2017-10-22 03:23:21 UTC
fedora-easy-karma-0-0.34.20171019gitbc16e916.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d136b70561

Comment 52 Fedora Update System 2017-10-25 23:55:39 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 53 Fedora Update System 2017-10-26 09:46:49 UTC
fedora-easy-karma-0-0.32.20170930git0c81432c.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 54 Fedora Update System 2017-12-09 04:56:19 UTC
fedora-easy-karma-0-0.34.20171019gitbc16e916.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.