Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1277689

Summary: Update of apache to 2.4.17 breaks passenger
Product: [Fedora] Fedora Reporter: Tom Hughes <tom>
Component: passengerAssignee: Jan Kalu┼ża <jkaluza>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: brett.lentz, jkaluza, ol+redhat, tdawson, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: passenger-4.0.59-3.fc23 passenger-4.0.53-4.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-26 20:59:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Tom Hughes 2015-11-03 20:24:59 UTC
Description of problem:

The update of apache from 2.4.16 to 2.4.17 that has just appeared in the F23 repos seems to break passenger.

After updating the passenger directive just seem to be ignored and apache tries to serve the public directory (ie the DocumentRoot) when you hit routes that rails should be handling.

Version-Release number of selected component (if applicable):

httpd-2.4.17-3.fc23.x86_64
passenger-4.0.59-2.fc23.x86_64

Comment 1 Tom Hughes 2015-11-03 21:04:59 UTC
https://bz.apache.org/bugzilla/show_bug.cgi?id=58498 may be the cause?

Comment 2 Tom Hughes 2015-11-03 21:07:24 UTC
Also https://github.com/phusion/passenger/pull/1642 which has a fix (for passenger 5 of course).

Comment 3 Tom Hughes 2015-11-03 21:11:03 UTC
Can confirm that disabling mod_autoindex in apache fixes it.

Comment 4 Fedora Update System 2015-11-04 09:22:34 UTC
passenger-4.0.59-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-fa0ae4f795

Comment 5 Fedora Update System 2015-11-04 10:23:16 UTC
passenger-4.0.53-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-bb7d5a9550

Comment 6 Fedora Update System 2015-11-05 01:28:23 UTC
passenger-4.0.59-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update passenger'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-fa0ae4f795

Comment 7 Fedora Update System 2015-11-05 15:52:53 UTC
passenger-4.0.53-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update passenger'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-bb7d5a9550

Comment 8 Fedora Update System 2015-11-26 20:59:46 UTC
passenger-4.0.59-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2016-01-19 23:56:46 UTC
passenger-4.0.53-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.