Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1283689

Summary: switching workspaces changes top-level window temporarily
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: mutterAssignee: Florian Müllner <fmuellner>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: fmuellner, ofourdan, otaylor, walters
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-01 06:54:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1277927    
Attachments:
Description Flags
bug demonstration video none

Description Kamil Páral 2015-11-19 15:20:08 UTC
Description of problem:
I have two apps on my current workspace, Firefox in front, Terminal in back. When I switch to a workspace below, Terminal is temporarily rendered as a top-level window, during the transition animation. When I switch back to the original workspace, I see again Firefox on top. This is quite jarring and uncomfortable, because the windows jump and flash every time I switch desktop.

This only occurs if I'm using two monitors and there's some window on the secondary screen. If there's no window, the bug doesn't occur.

I tried to capture a screencast. Due to low framerate, it's not that much visible, but in real conditions, the issue is much more obvious. In the video, please note that when Firefox is on top and I switch workspaces, terminal is temporarily rendered on top.

This only happens with Wayland.

Version-Release number of selected component (if applicable):
gnome-shell-3.18.2-2.fc23.x86_64
mutter-3.18.2-1.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1. have two monitors, open Firefox+Terminal on primary screen and 1 app (hexchat, gedit) on secondary screen
2. make Firefox foreground app
2. switch from first workspace to second workspace, see that the background app is rendered as foreground app temporarily

Comment 1 Kamil Páral 2015-11-19 15:21:31 UTC
Created attachment 1096719 [details]
bug demonstration video

Comment 2 Olivier Fourdan 2016-09-01 06:51:14 UTC
That bug is fixed upstream

Comment 3 Olivier Fourdan 2016-09-01 06:54:49 UTC
https://bugzilla.gnome.org/show_bug.cgi?id=764844