Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1285165

Summary: Items placed in desktop folder under wayland do not show on the desktop
Product: [Fedora] Fedora Reporter: Leslie Satenstein <lsatenstein>
Component: gnome-shellAssignee: Owen Taylor <otaylor>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 23CC: fedora, fmuellner, fschwarz, jylo06g, kparal, otaylor
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-12-08 11:23:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1277927    

Description Leslie Satenstein 2015-11-25 06:31:19 UTC
Description of problem:

Items placed in desktop folder under wayland do not show on the desktop 


Version-Release number of selected component (if applicable):

Gnome Wayland

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

No icons on desktop when an item is stored in ~/Desktop

Expected results:

Item to show on the desktop, as it does with Gnome classic 
and Gnome Standard (X11)

Additional info:

Tweak setting to show ~ icon and trash also not being presented.

Requested

Comment 1 Kamil Páral 2015-12-08 11:23:01 UTC

*** This bug has been marked as a duplicate of bug 1280195 ***

Comment 2 Jia Yuan Lo 2016-11-24 05:25:49 UTC
I don't think this should be categorised as duplicate for nautilus as this is in fact gnome-shell problem on Wayland

Even without gnome-tweak-tool
One can use dconf-editor or use gsettings command in Terminal

gsettings set org.gnome.desktop.background show-desktop-icons true

which is exactly what gnome-tweak-tool GUI does when you flip ON to show Desktop icons

Note that log off and then login under GNOME on X11, the Desktop icons are there

Back to GNOME on Wayland, nope.

Comment 3 Felix Schwarz 2016-11-30 21:30:01 UTC
(In reply to Jia Yuan Lo from comment #2)
> I don't think this should be categorised as duplicate for nautilus as this
> is in fact gnome-shell problem on Wayland (...)

While it seem strange the "nautilus" application is responsible for displaying the desktop icons so the resolution here is technically correct (even though I miss desktop icons personally).