Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1285242

Summary: Arranging screens has as result mouse events to be lost
Product: [Fedora] Fedora Reporter: Christos Triantafyllidis <christos.triantafyllidis>
Component: waylandAssignee: Adam Jackson <ajax>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: 24CC: ajax, ofourdan
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-31 07:50:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1277927    

Description Christos Triantafyllidis 2015-11-25 09:43:03 UTC
Description of problem:
I'm not quite sure if that is wayland or gnome issue but I see it only when I'm using wayland.

It looks like everytime I dock my laptop and re-arrange the screens I can only use the mouse to switch between windows but not to send any mouse events to the windows.

For example scrolling up and down my contact list in pidgin or clicking on different channels on xchat is not possible.

The issue is resolved after I undock the laptop (and re-dock it) but the screen arrangement is lost and when I re-arrange it I have the same issue.


Version-Release number of selected component (if applicable):
$ rpm -qa | grep wayland
xorg-x11-server-Xwayland-1.18.0-2.fc23.x86_64
ibus-wayland-1.5.11-1.fc23.x86_64
mesa-libwayland-egl-11.0.6-1.20151122.fc23.x86_64
gnome-session-wayland-session-3.18.1.2-2.fc23.x86_64
libwayland-client-1.9.0-1.fc23.x86_64
libwayland-client-1.9.0-1.fc23.i686
libwayland-cursor-1.9.0-1.fc23.x86_64
libwayland-server-1.9.0-1.fc23.i686
libwayland-server-1.9.0-1.fc23.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Dock laptop 
2. From gnome control-panel select "displays" and "arrange combined displays"
3. Change the arrangement and save
4. Try to scroll or click on any window.

Actual results:
Mouse events doesn't seem to be sent to the active window

Expected results:
Mouse events should be sent to the active window


Additional info:
I'm using a Dell with Dell docking station, not sure if that applies also when you just connect a 2nd screen and try to re-arrange.

Comment 1 Olivier Fourdan 2015-12-16 14:45:36 UTC
This sounds a lot like https://bugs.freedesktop.org/show_bug.cgi?id=92273
 which was fixed in Xwayland not too long ago.

Comment 2 Christos Triantafyllidis 2015-12-17 08:37:30 UTC
Indeed it does! Do you know if that commit is part of any package that I can test?

I'll be able to test it next week and after that only after 6th of January.

Comment 3 Christos Triantafyllidis 2016-06-28 13:11:19 UTC
This seems to happening with Fedora 24 too:
$ rpm -qa | grep wayland
libwayland-cursor-1.10.0-1.fc24.x86_64
mesa-libwayland-egl-11.2.2-2.20160614.fc24.x86_64
ibus-wayland-1.5.13-1.fc24.x86_64
libwayland-client-1.10.0-1.fc24.x86_64
xorg-x11-server-Xwayland-1.18.3-4.fc24.x86_64
libwayland-client-1.10.0-1.fc24.i686
libwayland-server-1.10.0-1.fc24.x86_64
gnome-session-wayland-session-3.20.1-1.fc24.x86_64
libwayland-server-1.10.0-1.fc24.i686

Comment 4 Olivier Fourdan 2016-06-28 14:44:21 UTC
If still present in F24 then I suspect this could be https://bugs.freedesktop.org/show_bug.cgi?id=95491 which was fixed in mutter with https://bugzilla.gnome.org/show_bug.cgi?id=766528

Comment 5 Christos Triantafyllidis 2016-08-31 07:50:13 UTC
Hello,

It was present in F24 when it was first released but not any more (or at least it hasn't happened to me for more than a week now.

From the above RPM list only packages that seem to have changed are:
gnome-session-wayland-session-3.20.2-1.fc24.x86_64
mesa-libwayland-egl-12.0.1-1.fc24.x86_64
xorg-x11-server-Xwayland-1.18.4-1.fc24.x86_64

I'm closing this bug report as I can't reproduce it any more, feel free to re-open it if anyone else can reproduce it.

Cheers,
Christos