Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1285727

Summary: Files in /var/log/carbon are never deleted
Product: [Fedora] Fedora EPEL Reporter: Richard <redhat>
Component: python-carbonAssignee: Piotr Popieluch <piotr1212>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: el6CC: jamielinux, jonathansteffan, piotr1212
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: python-carbon-0.9.15-6.fc25 python-carbon-0.9.15-6.fc23 python-carbon-0.10.0-0.1.rc1.fc24 python-carbon-0.9.15-6.el6 python-carbon-0.9.15-6.el7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-10-01 04:21:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Richard 2015-11-26 10:55:09 UTC
Description of problem:
Carbon rotates its own log files (except console.log) in /var/log/carbon but never deletes them. This will eventually fill up the /var/log partition.

Version-Release number of selected component (if applicable):
python-carbon-0.9.12-3.el6.1.noarch

How reproducible:
Run carbon-cache and send data to it on a regular basis.

Additional info:
/var/log/carbon/console.log should be rotated
Old files in /var/log/carbon should be deleted

Comment 1 Piotr Popieluch 2015-11-26 12:19:22 UTC
Thanks for reporting. 

This is actually fixed in version newer than EL6:

* Wed Oct 01 2014 Jamie Nguyen <jamielinux@fedoraproject.org> - 0.9.12-5
<< skip >>
- disable internal log rotation and include logrotate configuration
  for Fedora >= 21 and EPEL >= 7

I'm not sure what the reasoning was to not include it in existing el6 package, I guess it could break already existing installations,
 
Jamie, can you remember why you didn't include it in el6?

Comment 2 Jamie Nguyen 2015-12-14 12:48:49 UTC
(In reply to Piotr Popieluch from comment #1)
> Jamie, can you remember why you didn't include it in el6?

Sorry for late reply. I think the reason was that the change might surprise EL6 users, but please do what you think is best (since you are the one making all the recent effort on the graphite packages).

Comment 3 Fedora Update System 2016-09-18 20:18:50 UTC
python-carbon-0.9.15-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0a67e63a90

Comment 4 Fedora Update System 2016-09-18 21:40:39 UTC
python-carbon-0.9.15-6.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-207d0083f6

Comment 5 Fedora Update System 2016-09-18 21:40:58 UTC
python-carbon-0.9.15-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7d4e6e32bb

Comment 6 Fedora Update System 2016-09-18 21:41:19 UTC
python-carbon-0.9.15-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7d67b8413b

Comment 7 Fedora Update System 2016-09-18 21:41:36 UTC
python-carbon-0.9.15-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e69cb06cb1

Comment 8 Fedora Update System 2016-09-18 21:46:27 UTC
python-carbon-0.9.15-6.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-4d36a9407f

Comment 9 Fedora Update System 2016-09-20 19:59:52 UTC
python-carbon-0.9.15-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-207d0083f6

Comment 10 Fedora Update System 2016-09-22 01:18:19 UTC
python-carbon-0.9.15-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e69cb06cb1

Comment 11 Fedora Update System 2016-09-22 01:19:41 UTC
python-carbon-0.9.15-6.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-4d36a9407f

Comment 12 Fedora Update System 2016-09-22 01:25:45 UTC
python-carbon-0.9.15-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7d67b8413b

Comment 13 Fedora Update System 2016-09-22 01:27:13 UTC
python-carbon-0.9.15-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7d4e6e32bb

Comment 14 Fedora Update System 2016-09-24 15:14:43 UTC
python-carbon-0.9.15-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-09-29 02:49:33 UTC
graphite-web-0.10.0-0.1.rc1.fc24, python-carbon-0.10.0-0.1.rc1.fc24, python-whisper-0.10.0-0.1.rc1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ef3b002240

Comment 16 Fedora Update System 2016-10-01 04:21:25 UTC
python-carbon-0.9.15-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2016-10-11 19:55:38 UTC
graphite-web-0.10.0-0.1.rc1.fc24, python-carbon-0.10.0-0.1.rc1.fc24, python-whisper-0.10.0-0.1.rc1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2017-02-28 21:17:28 UTC
python-carbon-0.9.15-6.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2017-02-28 21:19:03 UTC
python-carbon-0.9.15-6.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.