Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1286342

Summary: Mouse cursor vanishes
Product: [Fedora] Fedora Reporter: Martin Vysny <vysny>
Component: waylandAssignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: ajax, kparal
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-30 10:20:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1277927    

Description Martin Vysny 2015-11-28 10:54:56 UTC
Description of problem:
I run a fair amount of XWayland-based windows (Thunderbird, Chromium, Intellij) along with Wayland native windows (gnome-terminal). I'm not yet sure what exactly causes this, but sometimes suddenly the cursor vanishes for all XWayland windows, and only appears when I move the cursor over a wayland native window, such as gnome-terminal.
Perhaps this is related: when moving the mouse cursor from wayland native window to xwayland window, the cursor retains its shape (for example it will retain its right+bottom dragging shape when leaving gnome-terminal through the bottom right corner) and is not changed to, say, the black arrow.

Version-Release number of selected component (if applicable):


How reproducible:
I do not know yet, I suspect that a few alt-tabs will cause this but I am not sure.

Steps to Reproduce:
1.
2.
3.

Actual results:
The cursor retains its shape as it was when it was leaving the native wayland window (for example, a gnome terminal).

Expected results:
Upon entering, say, Krusader, the cursor should change its shape to a black arrow.

Additional info:

Comment 1 Kamil Páral 2015-11-30 10:20:23 UTC
Seems to be the same as bug 1278316.

*** This bug has been marked as a duplicate of bug 1278316 ***