Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1288287

Summary: [abrt] gedit: wl_proxy_marshal_array_constructor(): gedit killed by SIGABRT
Product: [Fedora] Fedora Reporter: Dan Loomis <danloomis47>
Component: geditAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: fedora, mclasen, ofourdan, rstrode
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
URL: https://retrace.fedoraproject.org/faf/reports/bthash/da85641e1b97b7ad5194ed224f483b24b4d7e250
Whiteboard: abrt_hash:482bcebcd0d45f65e183e0bb36e64cedc01ba5ff;VARIANT_ID=workstation;
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-12 10:23:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1277927, 1372055    
Attachments:
Description Flags
File: backtrace
none
File: cgroup
none
File: core_backtrace
none
File: dso_list
none
File: environ
none
File: limits
none
File: maps
none
File: mountinfo
none
File: namespaces
none
File: open_fds
none
File: proc_pid_status
none
File: var_log_messages none

Description Dan Loomis 2015-12-04 02:04:50 UTC
Description of problem:
Opened two files in gedit.   Wanted to look at them side by side.   I tried to drag a tab to a separate Window.   gedit crashed.    Running Wayland if that makes any difference.    

Version-Release number of selected component:
gedit-3.18.2-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/gedit --gapplication-service
crash_function: wl_proxy_marshal_array_constructor
executable:     /usr/bin/gedit
global_pid:     3062
kernel:         4.2.6-301.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 wl_proxy_marshal_array_constructor at src/wayland-client.c:602
 #3 wl_proxy_marshal at src/wayland-client.c:648
 #4 wl_data_device_start_drag at /usr/include/wayland-client-protocol.h:999
 #5 _gdk_wayland_window_drag_begin at gdkdnd-wayland.c:378
 #6 gtk_drag_begin_internal at gtkdnd.c:2467
 #7 gtk_drag_begin_with_coordinates at gtkdnd.c:2637
 #8 gtk_notebook_motion_notify at gtknotebook.c:3495
 #9 _gtk_marshal_BOOLEAN__BOXEDv at gtkmarshalers.c:131
 #10 _g_closure_invoke_va at gclosure.c:864
 #13 gtk_widget_event_internal at gtkwidget.c:7692

Comment 1 Dan Loomis 2015-12-04 02:04:53 UTC
Created attachment 1102030 [details]
File: backtrace

Comment 2 Dan Loomis 2015-12-04 02:04:54 UTC
Created attachment 1102031 [details]
File: cgroup

Comment 3 Dan Loomis 2015-12-04 02:04:55 UTC
Created attachment 1102032 [details]
File: core_backtrace

Comment 4 Dan Loomis 2015-12-04 02:04:56 UTC
Created attachment 1102033 [details]
File: dso_list

Comment 5 Dan Loomis 2015-12-04 02:04:57 UTC
Created attachment 1102034 [details]
File: environ

Comment 6 Dan Loomis 2015-12-04 02:04:58 UTC
Created attachment 1102035 [details]
File: limits

Comment 7 Dan Loomis 2015-12-04 02:05:00 UTC
Created attachment 1102036 [details]
File: maps

Comment 8 Dan Loomis 2015-12-04 02:05:01 UTC
Created attachment 1102037 [details]
File: mountinfo

Comment 9 Dan Loomis 2015-12-04 02:05:02 UTC
Created attachment 1102038 [details]
File: namespaces

Comment 10 Dan Loomis 2015-12-04 02:05:03 UTC
Created attachment 1102039 [details]
File: open_fds

Comment 11 Dan Loomis 2015-12-04 02:05:04 UTC
Created attachment 1102040 [details]
File: proc_pid_status

Comment 12 Dan Loomis 2015-12-04 02:05:05 UTC
Created attachment 1102041 [details]
File: var_log_messages

Comment 13 Dan Loomis 2015-12-04 17:07:32 UTC
Reproduced easily.   Works as expected on X11.   Added Wayland related

Comment 14 Matthias Clasen 2016-09-01 02:03:14 UTC
*** Bug 1292876 has been marked as a duplicate of this bug. ***

Comment 15 Olivier Fourdan 2016-09-01 07:14:35 UTC
Cannot reproduce using gedit-3.21.90-1.fc25 (but cannot detach the tab either)

Comment 16 Olivier Fourdan 2016-09-01 07:16:16 UTC
Also, opening a new window (with gedit --new-window) and dragging a tab from the first window to the second works as expected.

Comment 17 Christian Stadelmann 2016-09-01 07:38:03 UTC
(In reply to Olivier Fourdan from comment #15)
> Cannot reproduce using gedit-3.21.90-1.fc25 (but cannot detach the tab
> either)

That's weird.

I cannot reproduce this bug either on F25 alpha live images, not even on F24 current gedit versions (3.20.2-1).

Comment 18 Olivier Fourdan 2016-09-01 08:30:33 UTC
(In reply to Christian Stadelmann from comment #17)
> I cannot reproduce this bug either on F25 alpha live images, not even on F24
> current gedit versions (3.20.2-1).

That's good news then! I suspect this might have been a gtk bug instead.

Comment 19 Matthias Clasen 2016-09-12 10:23:40 UTC
ok, I think we should close this then, if it can't be reproduced anymore.