Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1315745

Summary: Program linked to gperftools SIGSEGV
Product: [Fedora] Fedora Reporter: Marek Skalický <mskalick>
Component: gperftoolsAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: codonell, fweimer, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-03-08 14:20:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Marek Skalický 2016-03-08 14:03:56 UTC
Description of problem:
C++ unit tests of MongoDB are failing with SIGSEGV before they start.

Example output:
    (gdb) run
    Starting program: /mnt/disk/mongodb/mongodb-src-r3.2.3/build/opt/mongo/base/base_test
     
    Program received signal SIGSEGV, Segmentation fault.
    0x0000000000000000 in ?? ()
    (gdb) backtrace
    #0  0x0000000000000000 in ?? ()
    #1  0x00007ffff77019d0 in ?? ()
    #2  0x00007fffffffddd0 in ?? ()
    #3  0x00007ffff7703455 in ?? ()
    #4  0x0000000000000001 in ?? ()
    #5  0x00007ffff7de5670 in elf_machine_rela (skip_ifunc=<optimized out>, reloc_addr_arg=<optimized out>, version=<optimized out>, sym=<optimized out>, reloc=0x
    7ffff7480c98, map=0x7ffff7fdb4e0) at ../sysdeps/x86_64/dl-machine.h:310
    #6  elf_dynamic_do_Rela (skip_ifunc=<optimized out>, lazy=<optimized out>, nrelative=<optimized out>, relsize=<optimized out>, reladdr=<optimized out>, map=0x
    7ffff7fdb4e0) at do-rel.h:137
    #7  _dl_relocate_object (scope=<optimized out>, reloc_mode=<optimized out>, consider_profiling=<optimized out>, consider_profiling@entry=0) at dl-reloc.c:258
    #8  0x00007ffff7ddc9ef in dl_main (phdr=<optimized out>, phnum=<optimized out>, user_entry=<optimized out>, auxv=<optimized out>) at rtld.c:2066
    #9  0x00007ffff7df1c0c in _dl_sysdep_start (start_argptr=start_argptr@entry=0x7fffffffdfe0, dl_main=dl_main@entry=0x7ffff7dda950 <dl_main>) at ../elf/dl-sysde
    p.c:249
    #10 0x00007ffff7dddcb1 in _dl_start_final (arg=0x7fffffffdfe0) at rtld.c:305
    #11 _dl_start (arg=0x7fffffffdfe0) at rtld.c:411
    #12 0x00007ffff7dd9c88 in _start () from /lib64/ld-linux-x86-64.so.2
    #13 0x0000000000000001 in ?? ()
    #14 0x00007fffffffe2ec in ?? ()
    #15 0x0000000000000000 in ?? ()

When these tests are building with bundled version of gperftools-2.2 everything is OK.

Does someone know if this is fixed in 2.4.91 which is not in fedora yet?

Version-Release number of selected component (if applicable):
gperftools-2.4.90-3

How reproducible:
Build MongoDB unit tests in fedora 24.


Actual results:
Unit test binary exit with SIGSEGV.

Expected results:
Unit test binary starts to run and test.

Additional info:

Comment 1 Carlos O'Donell 2016-03-08 14:20:18 UTC

*** This bug has been marked as a duplicate of bug 1312462 ***