Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1324139

Summary: AttributeError: 'NoneType' object has no attribute 'get_pixel'
Product: [Fedora] Fedora Reporter: yucef sourani <youssef.m.sourani>
Component: gtk-recordmydesktopAssignee: Mat Booth <mat.booth>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: fedora, hedayatv, mat.booth, nphilipp, ppisar, youssef.m.sourani
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-01 10:42:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1277927    

Description yucef sourani 2016-04-05 15:29:48 UTC
Description of problem:
gtk-recordMyDesktop fails to run

Version-Release number of selected component:
gtk-recordmydesktop-0.3.8-16.fc24

Additional info:
cmdline:        /usr/bin/python gtk-recordMyDesktop
kernel:         4.6.0-0.rc0.git20.1.fc25.x86_64
uid:            1000
Description:	Fedora release 25 (Rawhide)

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/bin/gtk-recordMyDesktop", line 43, in <module>
    main()
  File "/usr/bin/gtk-recordMyDesktop", line 40, in main
    tr=rmdSimple.simpleWidget()
  File "/usr/lib/python2.7/site-packages/recordMyDesktop/rmdSimple.py", line 477, in __init__
    self.__subWidgets__()
  File "/usr/lib/python2.7/site-packages/recordMyDesktop/rmdSimple.py", line 86, in __subWidgets__
    self.image=sT.GtkThumbSelector(self,self.values[5],self.hidden,2000)
  File "/usr/lib/python2.7/site-packages/recordMyDesktop/rmdSelectThumb.py", line 69, in __init__
    self.__subsample__(sroot,self.wwidth,self.wheight,self.root,self.factor)
  File "/usr/lib/python2.7/site-packages/recordMyDesktop/rmdSelectThumb.py", line 79, in __subsample__
    im2.put_pixel(k/stride,i/stride,im1.get_pixel(k,i))
AttributeError: 'NoneType' object has no attribute 'get_pixel'

Comment 1 Jan Kurik 2016-07-26 04:39:49 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 2 yucef sourani 2016-09-09 00:05:18 UTC
The same problem in fedora 25 alpha x86_64

version : gtk-recordmydesktop-0.3.8-17.fc25.noarch

Comment 3 yucef sourani 2016-10-12 22:09:59 UTC
The same problem in fedora 25 Beta x86_64 .

version : gtk-recordmydesktop-0.3.8-17.fc25.noarch

Comment 4 Christian Stadelmann 2016-11-21 15:37:56 UTC
This bug has been present for more than two years. Is this package still maintained? If not, can you please ask for a new maintainer on fedora's devel mailing list or remove the package from Fedora?

Comment 5 Hedayat Vatankhah 2016-12-26 10:13:03 UTC
seems to be duplicate of bug #1146202.

Comment 6 Petr Pisar 2017-11-01 10:42:15 UTC

*** This bug has been marked as a duplicate of bug 1146202 ***