Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1327204

Summary: Two network connections reported by nmcli during installation on s390x
Product: [Fedora] Fedora Reporter: Jan Stodola <jstodola>
Component: NetworkManagerAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 24CC: bgalvani, dan, dcbw, fgiudici, lkundrak, psimerda, thaller
Target Milestone: ---   
Target Release: ---   
Hardware: s390x   
OS: Linux   
Whiteboard:
Fixed In Version: NetworkManager-1.2.4-2.fc24 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-19 19:50:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 467765    
Attachments:
Description Flags
journalctl
none
nmcli c show uuid 07f02cc1-670c-4dd1-9ece-07a6ec94ac1b
none
nmcli c show uuid 9a9d8330-64a4-4ed1-aef6-7ebb2eefce7d
none
[PATCH] device/ethernet: ignore s390 'portname' attribute when not set none

Description Jan Stodola 2016-04-14 12:43:32 UTC
Description of problem:
During installation of Fedora 24 on s390x I can see two network connections:

[anaconda root@test ~]# nmcli c
NAME    UUID                                  TYPE            DEVICE 
enca00  07f02cc1-670c-4dd1-9ece-07a6ec94ac1b  802-3-ethernet  enca00 
enca00  9a9d8330-64a4-4ed1-aef6-7ebb2eefce7d  802-3-ethernet  --     
[anaconda root@test ~]#

Version-Release number of selected component (if applicable):
NetworkManager-1.2.0-0.8.rc1.fc24

How reproducible:
always

Steps to Reproduce:
1. run installation on s390x

Actual results:
two network connections during the installation

Expected results:
just one network connection reported by nmcli

Additional info:
* the installation images were created locally by lorax-24.17-1.fc24, since there are no official F24 composes for s390x yet.

Comment 1 Jan Stodola 2016-04-14 12:44:02 UTC
Created attachment 1147234 [details]
journalctl

Comment 2 Jan Stodola 2016-04-14 12:44:58 UTC
Created attachment 1147235 [details]
nmcli c show uuid 07f02cc1-670c-4dd1-9ece-07a6ec94ac1b

Comment 3 Jan Stodola 2016-04-14 12:45:39 UTC
Created attachment 1147237 [details]
nmcli c show uuid 9a9d8330-64a4-4ed1-aef6-7ebb2eefce7d

Comment 4 Beniamino Galvani 2016-04-15 08:17:16 UTC
Created attachment 1147497 [details]
[PATCH] device/ethernet: ignore s390 'portname' attribute when not set

This patch should fix the issue, but I was not able to test it (yet).

Comment 5 Thomas Haller 2016-04-22 14:05:41 UTC
(In reply to Beniamino Galvani from comment #4)
> Created attachment 1147497 [details]
> [PATCH] device/ethernet: ignore s390 'portname' attribute when not set
> 
> This patch should fix the issue, but I was not able to test it (yet).

lgtm

Comment 6 Francesco Giudici 2016-04-28 07:14:48 UTC
patch lgtm too

Comment 8 Jan Stodola 2016-05-10 12:07:52 UTC
I've built NM rpms with the patch applied and created new installation images - this issue is not reproducible with the patch applied. It also resolves the issue reported in bug 1327169, so I will close that bug as a duplicate of this one.

Comment 9 Jan Stodola 2016-05-10 12:09:18 UTC
*** Bug 1327169 has been marked as a duplicate of this bug. ***

Comment 10 Dan Horák 2016-05-10 12:41:36 UTC
Where can we expect an update for NetworkManager package? It's blocking proper testing of F-24 on s390x.

Comment 11 Jan Stodola 2016-05-18 11:14:48 UTC
ping, any update here, please?

Comment 12 Dan Horák 2016-05-18 11:28:38 UTC
We already have NetworkManager-1.2.2-1.fc24 built, is the fix there?

Comment 13 Beniamino Galvani 2016-05-18 12:15:00 UTC
(In reply to Dan Horák from comment #12)
> We already have NetworkManager-1.2.2-1.fc24 built, is the fix there?

Yes, it is.

Comment 14 Fedora Update System 2016-08-05 07:53:10 UTC
NetworkManager-1.2.4-1.fc24 network-manager-applet-1.2.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 15 Fedora Update System 2016-08-05 21:21:45 UTC
NetworkManager-1.2.4-1.fc24, network-manager-applet-1.2.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 16 Fedora Update System 2016-08-18 16:39:15 UTC
NetworkManager-1.2.4-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fade485364

Comment 17 Fedora Update System 2016-08-19 00:56:58 UTC
NetworkManager-1.2.4-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fade485364

Comment 18 Fedora Update System 2016-08-19 10:29:23 UTC
network-manager-applet-1.2.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 19 Fedora Update System 2016-08-19 19:49:43 UTC
NetworkManager-1.2.4-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.