Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1337342

Summary: Upgrade to Fedora 24 breaks khal
Product: [Fedora] Fedora Reporter: W. Michael Petullo <mike>
Component: khalAssignee: Michele Baldessari <michele>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: fedora, michele
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: khal-0.8.2-1.fc24 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-05-28 03:33:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description W. Michael Petullo 2016-05-18 22:14:20 UTC
Description of problem:
I found that khal no longer works after upgrading from Fedora 23 to 24.

Version-Release number of selected component (if applicable):
khal-0.7.0-2.fc24.noarch
vdirsyncer-0.9.2-1.fc24.noarch

How reproducible:
Every time

Steps to Reproduce:
1. Upgrade to Fedora 24
2. Run khal

Actual results:
$ khal 
Traceback (most recent call last):
  File "/usr/bin/khal", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3141, in <module>
    @_call_aside
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3127, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3154, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 640, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 941, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 828, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'vdirsyncer' distribution was not found and is required by khal

Comment 1 W. Michael Petullo 2016-05-19 19:37:51 UTC
After looking at this some more, it looks like this results from the move of vdirsyncer to Python 3. Is is possible to build the khal package for Python 3 too?

Comment 2 Michele Baldessari 2016-05-19 21:16:55 UTC
Hi Michael,

apologies there. Yes it is because of that, I had a rebuild going but apparently
I need to split vdirsync in python2 and python3 subpackages because khard has not
migrated to python3. I will tackle it this weekend

cheers,
Michele

Comment 3 Fedora Update System 2016-05-22 20:23:53 UTC
khal-0.8.2-1.fc24 vdirsyncer-0.11.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-143a5dd156

Comment 4 Fedora Update System 2016-05-24 02:57:07 UTC
khal-0.8.2-1.fc24, vdirsyncer-0.11.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-143a5dd156

Comment 5 Fedora Update System 2016-05-28 03:33:20 UTC
khal-0.8.2-1.fc24, vdirsyncer-0.11.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.