Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1340603

Summary: gnome-shell killed by gitg
Product: [Fedora] Fedora Reporter: Christian Stadelmann <fedora>
Component: gnome-shellAssignee: Owen Taylor <otaylor>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 25CC: fmuellner, mclasen, ofourdan, otaylor
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-12 10:26:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1277927, 1372055    
Attachments:
Description Flags
a full backtrace by gdb from gnome-shell coredump none

Description Christian Stadelmann 2016-05-28 13:55:58 UTC
Created attachment 1162596 [details]
a full backtrace by gdb from gnome-shell coredump

Description of problem:
In some cases, gitg crashes gnome-shell

Version-Release number of selected component (if applicable):
gtk3-3.20.6-1.fc24.x86_64
glib2-2.48.1-1.fc24.x86_64
gnome-shell-3.20.2-1.fc24.x86_64
mutter-3.20.2-1.fc24.x86_64
gitg-3.20.0-1.fc24.x86_64
on a fully updated F24 beta with updates-testing enabled

How reproducible:
always for a specific set of git repositories

Steps to Reproduce:
1. Log in to a gnome+wayland session
2. start gitg
3. in gitg
3.1. press "Add", now in the dialog
3.2. select "Scan for all git repositories from this directory"
3.3. select a directory with many git repositories
3.4. press "Add"

Actual results:
Gnome-shell crashes

Expected results:
No crash. Gnome-shell must never die because of misbehaving applications.

Additional info:
#0  0x00007f2c7acffe55 in __GI_raise (sig=sig@entry=0x6)
    at ../sysdeps/unix/sysv/linux/raise.c:54
#1  0x00007f2c7ad01a5a in __GI_abort () at abort.c:89
#2  0x00007f2c7c8eff05 in g_assertion_message (domain=domain@entry=0x7f2c8047885c "mutter", file=file@entry=0x7f2c8047af72 "core/window.c", line=line@entry=0x54b, func=func@entry=0x7f2c8047d090 <__func__.83304> "meta_window_unmanage", message=message@entry=0x55c293bf8ef0 "assertion failed: (window->display->focus_window != window)") at gtestutils.c:2429
#3  0x00007f2c7c8eff9a in g_assertion_message_expr (domain=domain@entry=0x7f2c8047885c "mutter", file=file@entry=0x7f2c8047af72 "core/window.c", line=line@entry=0x54b, func=func@entry=0x7f2c8047d090 <__func__.83304> "meta_window_unmanage", expr=expr@entry=0x7f2c8047c008 "window->display->focus_window != window") at gtestutils.c:2452
#4  0x00007f2c80433bef in meta_window_unmanage (window=0x55c292e1ee60 [MetaWindowWayland], timestamp=0x3810bf) at core/window.c:1355
#5  0x00007f2c8045c8a3 in destroy_window (surface=0x55c296494670 [MetaWaylandSurface])
    at wayland/meta-wayland-surface.c:307
#6  0x00007f2c8045c92d in xdg_surface_destructor (resource=<optimized out>)
    at wayland/meta-wayland-surface.c:1306
#7  0x00007f2c7c01e56c in destroy_resource (element=0x55c295bc25c0, data=data@entry=0x0)
    at src/wayland-server.c:571
#8  0x00007f2c7c01ef34 in wl_resource_destroy (resource=<optimized out>)
    at src/wayland-server.c:584
#9  0x00007f2c7811ec58 in ffi_call_unix64 () at ../src/x86/unix64.S:76
#10 0x00007f2c7811e6ba in ffi_call (cif=cif@entry=0x7ffe6ad91e10, fn=<optimized out>, rvalue=<optimized out>, rvalue@entry=0x0, avalue=avalue@entry=0x7ffe6ad91ee0)
    at ../src/x86/ffi64.c:525
#11 0x00007f2c7c02305e in wl_closure_invoke (closure=closure@entry=0x55c2966e1810, flags=flags@entry=0x2, target=<optimized out>, 
    target@entry=0x55c295bc25c0, opcode=opcode@entry=0x0, data=<optimized out>, 
    data@entry=0x55c29508a130) at src/connection.c:949
#12 0x00007f2c7c01f406 in wl_client_connection_data (fd=<optimized out>, mask=<optimized out>, data=0x55c29508a130) at src/wayland-server.c:337
#13 0x00007f2c7c021265 in wl_event_loop_dispatch (loop=0x55c29115e1f0, timeout=timeout@entry=0x0) at src/event-loop.c:421
#14 0x00007f2c8044e2d7 in wayland_event_source_dispatch (base=base@entry=0x55c292722040, callback=<optimized out>, data=<optimized out>) at wayland/meta-wayland.c:77
#15 0x00007f2c7c8ca703 in g_main_context_dispatch (context=0x55c29115bf20) at gmain.c:3154
#16 0x00007f2c7c8ca703 in g_main_context_dispatch (context=context@entry=0x55c29115bf20)
    at gmain.c:3769
#17 0x00007f2c7c8caab0 in g_main_context_iterate (context=0x55c29115bf20, block=block@entry=0x1, dispatch=dispatch@entry=0x1, self=<optimized out>) at gmain.c:3840
#18 0x00007f2c7c8cadd2 in g_main_loop_run (loop=0x55c29272f830) at gmain.c:4034
#19 0x00007f2c80420a9c in meta_run () at core/main.c:537
#20 0x000055c2904c0567 in main (argc=<optimized out>, argv=<optimized out>) at main.c:471

Comment 1 Christian Stadelmann 2016-05-28 14:06:14 UTC
This crasher is specific to running gnome under wayland, it does not happen under X11.

In both cases there are no warnings in syslog and no crasher in gitg.

Comment 2 Olivier Fourdan 2016-08-31 15:52:55 UTC
Reproduced in current F25 with gnome-shell-3.21.90.1-1.fc25

Comment 4 Christian Stadelmann 2016-09-01 12:20:28 UTC
*** Bug 1372322 has been marked as a duplicate of this bug. ***

Comment 5 Christian Stadelmann 2016-09-01 12:21:35 UTC
Bug #1372322 has a new backtrace from F25 in case you need  one.

Comment 6 Olivier Fourdan 2016-09-02 06:57:14 UTC
A fix from Jonas for this bug has landed upstream: https://git.gnome.org/browse/mutter/commit/?id=6c8f6af

Comment 7 Christian Stadelmann 2016-09-08 14:15:52 UTC
(In reply to Olivier Fourdan from comment #6)
> A fix from Jonas for this bug has landed upstream:
> https://git.gnome.org/browse/mutter/commit/?id=6c8f6af

It will land with the next release after 3.21.91 then.

Comment 8 Matthias Clasen 2016-09-12 10:26:33 UTC
mutter 3.21.91 has been built