Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1342268

Summary: ugene 1.22.0-5 not built with $RPM_OPT_FLAGS
Product: [Fedora] Fedora Reporter: Ville Skytt√§ <ville.skytta>
Component: ugeneAssignee: Rex Dieter <rdieter>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: rdieter, yalgaer
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ugene-1.22.0-6.fc24 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-06-14 09:15:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 496968    

Description Ville Skyttä 2016-06-02 20:09:01 UTC
ugene 1.22.0-5 is not built with $RPM_OPT_FLAGS. 1.22.0-1.fc23 did not have this problem.

Looks like Rex has already fixed this once, but the fix has disappeared. The git log is somewhat messy and the package %changelog is cut to just a few latest revisions, so it's hard to find out what's going on.

https://lists.fedoraproject.org/archives/list/scm-commits@lists.fedoraproject.org/thread/MTWNSIR6HBB6BMV75IWXGXHZD7O45M3N/

Comment 1 Rex Dieter 2016-06-02 22:24:14 UTC
I strongly suspect the fix got lost when someone merged f23 branch (to master).

I can refix it the same way, as well is a few other cosmetic issues.

Comment 2 Rex Dieter 2016-06-03 19:25:01 UTC
This build should fix this (among other improvements):

%changelog
* Thu Jun 02 2016 Rex Dieter <rdieter> - 1.22.0-6
- fix -debuginfo, use %%qmake_qt5 macro mostly (#1342268)
- patch to avoid QMAKE_CFLAGS_ISYSTEM= hack
- add icon/desktop/mime scriptlets
- fix mimetype registration
- fix versioned qt5-qtbase runtime dep (#1306561)

Comment 3 Fedora Update System 2016-06-04 00:12:59 UTC
ugene-1.22.0-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-54554f20d4

Comment 4 Fedora Update System 2016-06-04 00:13:05 UTC
ugene-1.22.0-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-54554f20d4

Comment 5 Fedora Update System 2016-06-04 18:26:54 UTC
ugene-1.22.0-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-54554f20d4

Comment 6 Fedora Update System 2016-06-14 09:15:41 UTC
ugene-1.22.0-6.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.