Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1352164

Summary: multilib-rpm-config FTBFS on aarch64 epel7
Product: [Fedora] Fedora Reporter: D. Marlin <dmarlin>
Component: multilib-rpm-configAssignee: Pavel Raiskup <praiskup>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: praiskup, yselkowi
Target Milestone: ---Keywords: Patch, Reopened
Target Release: ---   
Hardware: aarch64   
OS: Linux   
Whiteboard:
Fixed In Version: multilib-rpm-config-1-6.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-24 21:48:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 922257, 1285484    
Attachments:
Description Flags
dist-git patch none

Description D. Marlin 2016-07-01 21:10:01 UTC
Description of problem:

multilib-rpm-config fails to build from source for Fedora EPEL7 on RHELSA-7.2.


Version-Release number of selected component (if applicable):

multilib-rpm-config-1-5.el7


How reproducible:

consistently


Steps to Reproduce:
1.  On a RHELSA-7.2 host:
     mock -r epel-7-aarch64 multilib-rpm-config-1-5.el7.src.rpm
2.
3.


Actual results:

    :
/builddir/build/BUILD/multilib-rpm-config-1/tests
+ pwd
+ sh /builddir/build/BUILD/multilib-rpm-config-1/tests/../multilib-info --multilib-capable
false
+ cp -r template really-works
+ sh /builddir/build/BUILD/multilib-rpm-config-1/tests/../multilib-fix --buildroot /builddir/build/BUILD/multilib-rpm-config-1/tests --file /really-works/header.h
INFO: multilib-fix: we don't need multilib haeder hack for 'aarch64' architecture (no-op)
+ gcc really-works/main.c
+ ./a.out
works!


RPM build errors:
+ test -f 'really-works/header-*.h'
error: Bad exit status from /var/tmp/rpm-tmp.IjDQYI (%check)
    Bad exit status from /var/tmp/rpm-tmp.IjDQYI (%check)


Expected results:

builds without errors.


Additional info:

Despite the fact that multilib-rpm-config is in koji for Fedora 24 secondary arch (AArch64):

  http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=384267

I tried building it (multilib-rpm-config-1-5.fc24) in mock on AArch64:

  curl -O http://arm.koji.fedoraproject.org/kojifiles/packages/multilib-rpm-config/1/5.fc24/src/multilib-rpm-config-1-5.fc24.src.rpm
  mock -r fedora-24-aarch64 multilib-rpm-config-1-5.fc24.src.rpm

but it fails with the same error.

Comment 1 Yaakov Selkowitz 2016-07-01 21:31:40 UTC
noarch packages are not rebuild in secondary kojis, they are just imported from primary.  Therefore, the supposed success of the arm-koji build does not prove anything.

Comment 2 Yaakov Selkowitz 2016-07-01 21:47:50 UTC
Reassigning to Fedora, as it too is affected and the epel package is kept in sync therewith.

Comment 3 Yaakov Selkowitz 2016-07-01 22:04:01 UTC
Created attachment 1175129 [details]
dist-git patch

Comment 4 Pavel Raiskup 2016-07-02 06:38:19 UTC
Thanks!  Pushed to el5+ and f22+.  I guess build is not needed.

Comment 5 Yaakov Selkowitz 2016-07-08 02:00:17 UTC
An epel7 build is required for CentOS's rebuild of EPEL for alternative arches.

Comment 6 Fedora Update System 2016-07-08 03:58:19 UTC
multilib-rpm-config-1-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-3186496623

Comment 7 Fedora Update System 2016-07-10 03:17:54 UTC
multilib-rpm-config-1-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-3186496623

Comment 8 Fedora Update System 2016-07-24 21:48:55 UTC
multilib-rpm-config-1-6.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.