Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1357005

Summary: wrong path to shared object, ide doesn't start
Product: [Fedora] Fedora Reporter: steubens
Component: arduinoAssignee: Dennis Chen <barracks510>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: barracks510, giallu, jonathan, mavit, surkum, tchollingsworth, thozza, turgut
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard:
Fixed In Version: arduino-1.6.4-8.fc24 arduino-1.6.4-8.fc23 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-24 20:20:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description steubens 2016-07-15 13:08:07 UTC
Description of problem:
arduino ide fails to startup due to looking for .so on wrong path for arch

Steps to Reproduce:
1. dnf install arduino
2. arduino
3. click ignore on the group warning popup

Actual results:
Can't load library: /usr/lib64/libastyle.so
Cannot load native library /usr/lib64/libastyle.so
The program has terminated!

Additional info:
[_@_ ~]$  locate libastyle
/usr/lib/libastyle-2.05.so
/usr/lib/libastyle.so

Comment 1 Fedora Update System 2016-07-16 01:56:46 UTC
arduino-1.6.4-8.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5d792e30d2

Comment 2 Fedora Update System 2016-07-16 02:03:21 UTC
arduino-1.6.4-8.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bca019275a

Comment 3 Fedora Update System 2016-07-16 22:56:54 UTC
arduino-1.6.4-8.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5d792e30d2

Comment 4 Fedora Update System 2016-07-17 16:23:07 UTC
arduino-1.6.4-8.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bca019275a

Comment 5 steubens 2016-07-17 22:58:11 UTC
not sure of language in last comment 'if problems still persist', it is fixed, what's rhbz convention? should i close the bug and mark it fixed?

thanks

Comment 6 Dennis Chen 2016-07-18 16:33:44 UTC
The bug will close itself once the package reaches the stable repository. 

Thanks for reporting the bug.

Comment 7 Dennis Chen 2016-07-19 15:58:29 UTC
*** Bug 1357903 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2016-07-24 20:20:42 UTC
arduino-1.6.4-8.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2016-07-25 03:18:44 UTC
arduino-1.6.4-8.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Turgut Kalfaoglu 2017-07-17 10:37:08 UTC
Problem exists under fedora 26, somewhat differently. 

Installed arduino IDE using dnf.
Running it gives:

Can't load library: /usr/lib/libastyle-2.05.so
Cannot load native library /usr/lib/libastyle-2.05.so

both astyle, astyle-devel and astyle.i686 are loaded.

 $ locate astyle
/usr/bin/astyle
/usr/include/astyle.h
/usr/lib/libastyle.so.3
/usr/lib/libastyle.so.3.0.1
/usr/lib64/libastyle.so
/usr/lib64/libastyle.so.3
/usr/lib64/libastyle.so.3.0.1

Comment 11 Gianluca Sforna 2017-07-17 15:18:34 UTC
(In reply to Turgut Kalfaoglu from comment #10)
> Problem exists under fedora 26, somewhat differently. 
> 
> Installed arduino IDE using dnf.
> Running it gives:
> 
> Can't load library: /usr/lib/libastyle-2.05.so
> Cannot load native library /usr/lib/libastyle-2.05.so

That would be bug #1444550, update is going in stable in two days unless you give karma to it ;)