Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1370262

Summary: catalina.out is no longer in use in the main package, but still gets rotated
Product: [Fedora] Fedora Reporter: Coty Sutherland <csutherl>
Component: tomcatAssignee: Coty Sutherland <csutherl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: alee, coolsvap, csutherl, ivan.afonichev, java-sig-commits, krzysztof.daniel, tomcat-qe, trick
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: tomcat-8.0.38-1.fc24 tomcat-8.0.38-1.fc23 tomcat-8.0.38-1.fc25 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1370261 Environment:
Last Closed: 2016-11-12 23:52:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1370261    
Bug Blocks:    

Description Coty Sutherland 2016-08-25 18:30:00 UTC
+++ This bug was initially created as a clone of Bug #1370261 +++

Description of problem:
After the update from systemv to systemd for tomcat the service no longer writes console output to catalina.out. Instead, all of the console output is just written to stdout, which is received by the journal (and can be reviewed with `journalctl -u tomcat`. This means that nothing is redirected to catalina.out like systemv did, and therefore it's always empty. Additionally, there is a logrotate script included in the package that rotates the empty file weekly.

Version-Release number of selected component (if applicable):
tomcat-7.0.69-10.el7.noarch

How reproducible:
Always.

Steps to Reproduce:
1. `yum install tomcat` to get the package installed (note that it installs an empty catalina.out file in /var/log/tomcat)
2. `service tomcat start && service tomcat stop` to get some logging
3. Observe that /var/log/tomcat/catalina.out remains empty while another file (catalina.$(date).log) is populated with the logging. You can also see the stdout by using `journalctl -u tomcat`.

Actual results:
The tomcat processes stdout is no longer redirected to catalina.out, but instead received by the journal.

Expected results:
This is expected behavior, but the bug is being filed to cleanup the catalina.out file and logrotate script that rotates it.

Additional info:
The file and script can be deleted because tomcat handles it's on file rotation by default.

Comment 1 Coty Sutherland 2016-09-13 18:47:16 UTC
I moved catalina.out and the logrotate script into the JSVC subpackage, where it's actually used.

http://pkgs.fedoraproject.org/cgit/rpms/tomcat.git/commit/?id=55c043f

Comment 2 Fedora Update System 2016-10-25 01:22:49 UTC
tomcat-8.0.37-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4094bd4ad6

Comment 3 Fedora Update System 2016-10-25 02:22:36 UTC
tomcat-8.0.37-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c1b01b9278

Comment 4 Fedora Update System 2016-10-25 04:22:29 UTC
tomcat-8.0.37-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-38e5b05260

Comment 5 Fedora Update System 2016-10-26 17:50:46 UTC
tomcat-8.0.38-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4094bd4ad6

Comment 6 Fedora Update System 2016-10-26 20:33:17 UTC
tomcat-8.0.38-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-38e5b05260

Comment 7 Fedora Update System 2016-10-26 22:27:13 UTC
tomcat-8.0.38-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c1b01b9278

Comment 8 Fedora Update System 2016-11-12 23:52:18 UTC
tomcat-8.0.38-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2016-11-13 02:20:44 UTC
tomcat-8.0.38-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-11-19 21:02:00 UTC
tomcat-8.0.38-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.