Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1375560

Summary: Popup menus are misplaced when connected to external monitor and monitors not exactly side-by-side
Product: [Fedora] Fedora Reporter: Noam Cohen <noamcohen1>
Component: mutter-waylandAssignee: Adam Jackson <ajax>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: ajax, awilliam, beland, extras-orphan, jstpierr, noamcohen1
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-24 08:31:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1277927    
Attachments:
Description Flags
Screenshot when lid is open (popup menu created not as expected)
none
Screenshot when lid is closed (popup menu created as expected)
none
My displays arrangement
none
Output of "lshw" command
none
Output of "xrandr" command (shows details for XWAYLAND0 and XWAYLAND1) none

Description Noam Cohen 2016-09-13 12:07:10 UTC
Created attachment 1200476 [details]
Screenshot when lid is open (popup menu created not as expected)

Description of problem:


Version-Release number of selected component (if applicable):
Fedora 24

How reproducible:


Steps to Reproduce:
1. Login to a "Gnome on Wayland" session
2. Connect laptop to external monitor so that both displays are active.
3. Start an application (for example - Gnome Terminal)
4. Right click inside the terminal to open up a popup menu
5. Menu is not created where expected (problem)
6. Close laptop lid so that only external monitor is active
7. Right click to open the popup menu again - This time the menu will be created where expected


See both screenshots attached - "lid is closed.png" shows the popup menu inside the terminal window, as expected. "lid is open.png" shows the popup menu on the right (external) display created below the terminal window.

Comment 1 Noam Cohen 2016-09-13 12:07:51 UTC
Created attachment 1200477 [details]
Screenshot when lid is closed (popup menu created as expected)

Comment 2 Noam Cohen 2016-09-13 12:50:34 UTC
Not sure if it's related - but the two displays are not arranged side by side. See "Displays Arranagement.png" screenshot.

Comment 3 Noam Cohen 2016-09-13 12:51:00 UTC
Created attachment 1200484 [details]
My displays arrangement

Comment 4 Christopher Beland 2016-10-05 17:00:39 UTC
I'm experiencing a similar problem with Firefox and side-by-side monitors (built-in to the left of external) at different resolutions (1680x1050 and 2560x1440, respectively).  When I have Firefox full-screen on my *external* monitor and click on Edit, or View (but not File, the leftmost Firefox menu item), the popup appears on the *built-in* monitor, in the upper-left quadrant.

Comment 5 Noam Cohen 2016-10-14 09:48:44 UTC
Problem persists in Fedora 25 Beta. I checked things further, and it seems that as long as the two displays are arranged (combined) exactly side by side - the popup menus appear where expected. When I click on the "Arrange Combine Displays" button and drags one of the displays a little bit lower than the other - the problem starts.
Unlike for Christopher Beland - in my case both displays have the same resolution (1920x1080). Not sure if it is required, but  I'm also attaching the output of my "lshw" and "xrandr" commands.

Comment 6 Noam Cohen 2016-10-14 09:49:55 UTC
Created attachment 1210449 [details]
Output of "lshw" command

Comment 7 Noam Cohen 2016-10-14 09:51:06 UTC
Created attachment 1210450 [details]
Output of "xrandr" command (shows details for XWAYLAND0 and XWAYLAND1)

Comment 8 Noam Cohen 2016-11-24 08:31:22 UTC
Seems to be resolved in Fedora 25