Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1376444

Summary: valgrind breaks due to option "--alignment=8"
Product: [Fedora] Fedora Reporter: Christian Stadelmann <fedora>
Component: gnome-valgrind-sessionAssignee: Debarshi Ray <debarshir>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: debarshir
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: gnome-valgrind-session-1.1-14.fc24 gnome-valgrind-session-1.1-15.fc26 gnome-valgrind-session-1.1-14.fc25 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-08-07 01:20:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Christian Stadelmann 2016-09-15 12:42:17 UTC
Description of problem:
Valgrind sessions don't work.

Version-Release number of selected component (if applicable):
gnome-valgrind-session-1.1-13.fc24.noarch

How reproducible:
I don't know.

Steps to Reproduce:
1. try to login to a gnome valgrind session (error detection or leak detection, doesn't matter)
2. have a look at syslog

Actual results:
Session immediately exits.
valgrind complains:

valgrind: Bad option: --alignment=8
valgrind: Alignment must be a power of 2 in the range 16..4096.
valgrind: Use --help for more information or consult the user manual

Expected results:
Session should run, valgrind should only get valid input

Additional info:
simply removing the "--alignment=8" fixes the issue for me.

Comment 1 Debarshi Ray 2017-07-26 15:59:48 UTC
The man page says:

       --alignment=<number> [default: 8 or 16, depending on the platform]
           By default Valgrind's malloc, realloc, etc, return a block whose
           starting address is 8-byte aligned or 16-byte aligned (the value
           depends on the platform and matches the platform default). This
           option allows you to specify a different alignment. The supplied
           value must be greater than or equal to the default, less than or
           equal to 4096, and must be a power of two.

I guess things have changed in the last eleven years (bug 216517). 8 might have been a valid value (or the default?) on the relevant architectures back then. However, since this is a noarch package, I agree that the best recourse is to drop the --alignment parameter completely.

Comment 2 Fedora Update System 2017-07-26 16:55:31 UTC
gnome-valgrind-session-1.1-15.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4b45b98198

Comment 3 Fedora Update System 2017-07-26 16:57:22 UTC
gnome-valgrind-session-1.1-14.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3532b06ebc

Comment 4 Fedora Update System 2017-07-27 09:19:02 UTC
gnome-valgrind-session-1.1-14.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8e5d529299

Comment 5 Fedora Update System 2017-07-27 22:51:01 UTC
gnome-valgrind-session-1.1-14.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8e5d529299

Comment 6 Fedora Update System 2017-07-27 23:23:12 UTC
gnome-valgrind-session-1.1-14.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3532b06ebc

Comment 7 Fedora Update System 2017-07-28 01:52:12 UTC
gnome-valgrind-session-1.1-15.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4b45b98198

Comment 8 Fedora Update System 2017-08-07 01:20:22 UTC
gnome-valgrind-session-1.1-14.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2017-08-09 15:57:30 UTC
gnome-valgrind-session-1.1-15.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-08-09 19:58:15 UTC
gnome-valgrind-session-1.1-14.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.