Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1397238

Summary: An internal error occurred during: "Open Call Hierarchy action".
Product: [Fedora] Fedora Reporter: Chen_Min_Chin <tcfxfzoi>
Component: eclipse-pdtAssignee: Mat Booth <mat.booth>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: akurtako, andjrobins, dev002, eclipse-sig, fedora, jerboaa, krzysztof.daniel, mat.booth, mike, rgrunber, simon
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:14710826;VARIANT_ID=workstation;
Fixed In Version: eclipse-pdt-4.2.0-1.fc25 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-19 05:55:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
File: backtrace none

Description Chen_Min_Chin 2016-11-22 01:32:34 UTC
Version-Release number of selected component:
eclipse-platform-4.6.1-5.fc24

Additional info:
reporter:       libreport-2.7.2
cmdline:        /usr/bin/java -Dosgi.requiredJavaVersion=1.8 -Xms128m -Xmx1024m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.200.v20160915-0852.jar -os linux -ws gtk -arch x86_64 -showsplash /usr/lib64/eclipse//plugins/org.eclipse.platform_4.6.1.v20160915-0852/splash.bmp -launcher /usr/lib64/eclipse/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.400.v20160915-0852/eclipse_1617.so -startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.200.v20160915-0852.jar -protect master --launcher.appendVmargs -exitdata 4e000d -vm /usr/bin/java -vmargs -Dosgi.requiredJavaVersion=1.8 -Xms128m -Xmx1024m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.200.v20160915-0852.jar
eclipseplugin:  org.eclipse.core.jobs
executable:     /usr/lib64/eclipse/plugins/org.eclipse.core.jobs_3.8.0.v20160915-0852.jar
kernel:         4.8.6-201.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           libreport
uid:            1000

Truncated backtrace:
java.lang.NullPointerException
	at org.eclipse.dltk.internal.core.hierarchy.TypeHierarchy.getAllClasses(TypeHierarchy.java:448)
	at org.eclipse.dltk.internal.core.hierarchy.TypeHierarchy.getAllTypes(TypeHierarchy.java:548)
	at org.eclipse.php.internal.core.typeinference.evaluators.phpdoc.PHPDocClassVariableEvaluator.init(PHPDocClassVariableEvaluator.java:75)
	at org.eclipse.dltk.ti.GoalEngine.evaluateGoal(GoalEngine.java:225)
	at org.eclipse.dltk.ti.DefaultTypeInferencer.evaluateType(DefaultTypeInferencer.java:219)
	at org.eclipse.dltk.ti.DefaultTypeInferencer.evaluateType(DefaultTypeInferencer.java:227)
	at org.eclipse.php.internal.core.typeinference.PHPTypeInferenceUtils.resolveExpression(PHPTypeInferenceUtils.java:86)
	at org.eclipse.php.internal.core.typeinference.PHPTypeInferenceUtils.resolveExpression(PHPTypeInferenceUtils.java:80)
	at org.eclipse.php.internal.core.codeassist.PHPSelectionEngine.processPHPCallExpression(PHPSelectionEngine.java:810)
	at org.eclipse.php.internal.core.codeassist.PHPSelectionEngine.internalASTResolve(PHPSelectionEngine.java:288)
	at org.eclipse.php.internal.core.codeassist.PHPSelectionEngine.select(PHPSelectionEngine.java:106)
	at org.eclipse.dltk.internal.core.Openable.codeSelect(Openable.java:679)
	at org.eclipse.dltk.internal.core.Openable.codeSelect(Openable.java:695)
	at org.eclipse.dltk.internal.core.AbstractSourceModule.codeSelect(AbstractSourceModule.java:91)
	at org.eclipse.dltk.internal.core.AbstractSourceModule.codeSelect(AbstractSourceModule.java:85)
	at org.eclipse.php.internal.ui.util.PHPSelectionUtil.getSelectionModelElement(PHPSelectionUtil.java:70)
	at org.eclipse.php.internal.ui.actions.OpenCallHierarchyAction.isEnabled(OpenCallHierarchyAction.java:144)
	at org.eclipse.php.internal.ui.actions.OpenCallHierarchyAction.access$0(OpenCallHierarchyAction.java:138)
	at org.eclipse.php.internal.ui.actions.OpenCallHierarchyAction$1.run(OpenCallHierarchyAction.java:93)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Comment 1 Chen_Min_Chin 2016-11-22 01:32:40 UTC
Created attachment 1222534 [details]
File: backtrace

Comment 2 Remi Collet 2016-11-23 15:53:52 UTC
Same issue, and some  more

    An internal error occurred during: "Initializing PHP Tooling".
        org/apache/lucene/store/RAFDirectory


BTW using upstream 4.6.1 tarball works.

Comment 3 Remi Collet 2016-11-25 09:21:25 UTC
# rpm -qa eclipse\* | sort
eclipse-abrt-0.0.3-1.fc25.noarch
eclipse-dltk-5.6.0-1.fc25.noarch
eclipse-dltk-mylyn-5.6.0-1.fc25.noarch
eclipse-e4-importer-0.2.0-0.2.gitb33919c.fc25.noarch
eclipse-ecf-core-3.13.2-1.fc25.x86_64
eclipse-emf-core-2.12.0-1.fc25.x86_64
eclipse-emf-runtime-2.12.0-1.fc25.noarch
eclipse-epp-logging-2.0.3-1.fc25.noarch
eclipse-equinox-osgi-4.6.1-6.fc25.x86_64
eclipse-filesystem-1.0-7.fc24.x86_64
eclipse-gef-3.11.0-1.fc25.noarch
eclipse-jdt-4.6.1-6.fc25.noarch
eclipse-mylyn-3.20.2-2.fc25.noarch
eclipse-mylyn-tasks-bugzilla-3.20.2-2.fc25.noarch
eclipse-nls-4.6.0-1.fc25.noarch
eclipse-p2-discovery-4.6.1-6.fc25.noarch
eclipse-pde-4.6.1-6.fc25.x86_64
eclipse-pdt-4.1.0-2.fc25.noarch
eclipse-platform-4.6.1-6.fc25.x86_64
eclipse-swt-4.6.1-6.fc25.x86_64
eclipse-webtools-common-3.8.1-1.fc25.noarch
eclipse-webtools-servertools-3.8.1-1.fc25.noarch
eclipse-webtools-sourceediting-3.8.1-1.fc25.noarch
eclipse-xsd-2.12.0-1.fc25.noarch

Comment 4 Michael Rosile 2016-12-14 20:27:09 UTC
I have the same issues as reported by Chen_Min_Chin and Remi Collet, and I am using Fedora 25 (64-bit).  My RPM packages match those listed by Remi.

Eclipse > Help > About, shows the version as being:
Version: Neon.1 (4.6.1)
Build id: Z20161111-1340

When using the Eclipse PDT bundle provided by eclipse.org, I don't have these issues.

Eclipse > Help > About, shows eclipse.org version as being:
Version: Neon.1a Release (4.6.1)
Build id: 20161007-1200

Initially I noticed that the PDT bundle from eclipse.org, is using an earlier version of Apache Lucene, v3.5.0, while the Fedora 25 version is v5.5.0.

I'm happy to provide additional info / logs if need be.

Comment 5 dev002 2016-12-16 17:50:09 UTC
Same here on PDT, eclipse not usable with the repeated "dialogs".
Open a PHP file, click on some code and results in: "Open Type Hierarchy action. java.lang.NullPointerException"

Eclipse is not usable.

Comment 6 Mat Booth 2017-01-11 14:43:10 UTC
*** Bug 1403476 has been marked as a duplicate of this bug. ***

Comment 7 Mat Booth 2017-01-11 15:33:33 UTC
*** Bug 1397967 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2017-01-11 22:23:11 UTC
eclipse-ecf-3.13.3-1.fc25 eclipse-4.6.2-2.fc25 eclipse-jgit-4.6.0-2.fc25 eclipse-egit-4.6.0-1.fc25 eclipse-dltk-5.7.0-1.fc25 eclipse-pdt-4.2.0-1.fc25 eclipse-mpc-1.5.3-1.fc25 lucene4-4.10.4-7.fc25 eclipse-epp-logging-2.0.3-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ddde4436aa

Comment 9 Fedora Update System 2017-01-12 07:54:01 UTC
eclipse-4.6.2-2.fc25, eclipse-dltk-5.7.0-1.fc25, eclipse-ecf-3.13.3-1.fc25, eclipse-egit-4.6.0-1.fc25, eclipse-epp-logging-2.0.3-2.fc25, eclipse-jgit-4.6.0-2.fc25, eclipse-mpc-1.5.3-1.fc25, eclipse-pdt-4.2.0-1.fc25, lucene4-4.10.4-7.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ddde4436aa

Comment 10 Fedora Update System 2017-01-12 11:03:03 UTC
ecj-4.6.2-1.fc25 eclipse-4.6.2-2.fc25 eclipse-dltk-5.7.0-1.fc25 eclipse-ecf-3.13.3-1.fc25 eclipse-egit-4.6.0-1.fc25 eclipse-egit-github-4.6.0-1.fc25 eclipse-epp-logging-2.0.3-2.fc25 eclipse-jgit-4.6.0-2.fc25 eclipse-mpc-1.5.3-1.fc25 eclipse-pdt-4.2.0-1.fc25 lucene4-4.10.4-7.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ddde4436aa

Comment 11 Fedora Update System 2017-01-13 08:31:11 UTC
ecj-4.6.2-1.fc25, eclipse-4.6.2-3.fc25, eclipse-dltk-5.7.0-1.fc25, eclipse-ecf-3.13.3-1.fc25, eclipse-egit-4.6.0-1.fc25, eclipse-egit-github-4.6.0-1.fc25, eclipse-epp-logging-2.0.3-2.fc25, eclipse-jgit-4.6.0-2.fc25, eclipse-mpc-1.5.3-1.fc25, eclipse-pdt-4.2.0-1.fc25, lucene4-4.10.4-7.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ddde4436aa

Comment 12 Fedora Update System 2017-01-19 05:55:18 UTC
ecj-4.6.2-1.fc25, eclipse-4.6.2-3.fc25, eclipse-dltk-5.7.0-1.fc25, eclipse-ecf-3.13.3-1.fc25, eclipse-egit-4.6.0-1.fc25, eclipse-egit-github-4.6.0-1.fc25, eclipse-epp-logging-2.0.3-2.fc25, eclipse-jgit-4.6.0-2.fc25, eclipse-mpc-1.5.3-1.fc25, eclipse-pdt-4.2.0-1.fc25, lucene4-4.10.4-7.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Mat Booth 2017-01-25 10:18:21 UTC
*** Bug 1403475 has been marked as a duplicate of this bug. ***