Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1404631

Summary: nbdkit: nbdkit-plugin-python3 requires a Python 2 package
Product: [Fedora] Fedora Reporter: Iryna Shcherbina <ishcherb>
Component: nbdkitAssignee: Richard W.M. Jones <rjones>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: rjones
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: nbdkit-1.1.12-4.fc26 nbdkit-1.1.25-1.fc27 nbdkit-1.1.25-1.fc26 nbdkit-1.1.25-1.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-19 19:46:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1285816    

Description Iryna Shcherbina 2016-12-14 10:09:26 UTC
The nbdkit-plugin-python3 RPM depends on a Python 2 package.

$ rpm -qRp nbdkit-plugin-python3-1.1.12-3.fc24.x86_64.rpm 
...
libpython2.7.so.1.0()(64bit)
...

Except in very special circumstances, there is no need for a Python 3 package
to drag in Python 2 stack. Usually, this is a packaging error: for example, using Python 2 when building.

Please remove the stray dependency.

It's ok to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 25 as well.


If anything is unclear, or if you need any kind of assistance, you can
ask on IRC (#fedora-python on Freenode), or reply here. We'll be happy
to help investigating or fixing this issue!


[0] http://python-rpm-porting.readthedocs.io/en/latest/application-modules.html#are-shebangs-dragging-you-down-to-python-2

Comment 1 Richard W.M. Jones 2016-12-14 10:51:00 UTC
In fact it was building the python3 plugin with python 2.  The
root cause was because:

PYTHON=/usr/bin/python3 %configure

does not do what you expect, because the %configure macro
expands to multiple separate commands.

This is fixed in:

http://pkgs.fedoraproject.org/cgit/rpms/nbdkit.git/commit/?id=0f5a14fa20d70679128bb2f3456979b91715497e

There is no python3 subpackage in Fedora 25, so this is
only fixed in Rawhide.

Comment 2 Richard W.M. Jones 2016-12-14 10:53:50 UTC
https://koji.fedoraproject.org/koji/taskinfo?taskID=16883036

Comment 3 Iryna Shcherbina 2016-12-15 09:48:21 UTC
Thanks for a prompt response and fix.

Comment 4 Iryna Shcherbina 2017-11-27 10:00:38 UTC
Hi Richard,

since commit [0] Python 3 plugin for nbdkit is no longer built for Fedora. Is there any specific reason for this? Can it be enabled for Fedora as well?

[0] https://src.fedoraproject.org/rpms/nbdkit/c/f38f61c339f925928e8cd6e520581968105ada96

Comment 5 Richard W.M. Jones 2017-11-27 10:35:28 UTC
Oh bugger.  Yes you're right, I should have used something like
0%{fedora} || 0%{rhel} >= 8.  I'll see if I can fix the macros ...

Comment 6 Richard W.M. Jones 2017-11-29 19:44:34 UTC
This should be fixed in nbdkit-1.1.18-4.fc28 (Rawhide)
and nbdkit-1.1.18-4.el7 (EPEL 7).

Comment 7 Fedora Update System 2017-11-29 19:46:26 UTC
nbdkit-1.1.18-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-f4e504436e

Comment 8 Fedora Update System 2017-11-29 19:59:04 UTC
nbdkit-1.1.18-4.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-796fcdc5ad

Comment 9 Fedora Update System 2017-11-29 20:09:56 UTC
nbdkit-1.1.18-4.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5c31c3c9c

Comment 10 Fedora Update System 2017-12-02 19:53:13 UTC
nbdkit-1.1.18-4.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-796fcdc5ad

Comment 11 Fedora Update System 2017-12-02 21:47:41 UTC
nbdkit-1.1.18-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-f4e504436e

Comment 12 Fedora Update System 2017-12-02 22:38:53 UTC
nbdkit-1.1.18-4.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5c31c3c9c

Comment 13 Fedora Update System 2017-12-06 19:47:18 UTC
nbdkit-1.1.25-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-6fd20dea26

Comment 14 Fedora Update System 2017-12-06 19:47:31 UTC
nbdkit-1.1.25-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1e8887df62

Comment 15 Fedora Update System 2017-12-09 06:55:54 UTC
nbdkit-1.1.25-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-6fd20dea26

Comment 16 Fedora Update System 2017-12-09 07:27:26 UTC
nbdkit-1.1.25-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1e8887df62

Comment 17 Fedora Update System 2017-12-10 21:48:07 UTC
libguestfs-1.37.34-3.fc27, nbdkit-1.1.25-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4d91b4dadf

Comment 18 Fedora Update System 2017-12-19 19:46:32 UTC
libguestfs-1.37.34-3.fc27, nbdkit-1.1.25-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2017-12-19 21:34:26 UTC
nbdkit-1.1.25-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2017-12-27 23:58:39 UTC
nbdkit-1.1.25-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.