Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1412924

Summary: bacula: FTBFS in Fedora Rawhide
Product: [Fedora] Fedora Reporter: Igor Gnatenko <ignatenko>
Component: baculaAssignee: Simone Caronni <negativo17>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: andreas, gwync, jridky, negativo17, phracek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-13 14:36:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1383740    

Description Igor Gnatenko 2017-01-13 06:56:36 UTC
crypto.c:196:1: error: expected constructor, destructor, or type conversion before 'IMPLEMENT_STACK_OF'
 IMPLEMENT_STACK_OF(RecipientInfo)
 ^~~~~~~~~~~~~~~~~~
crypto.c:273:15: error: field 'ctx' has incomplete type 'EVP_MD_CTX {aka evp_md_ctx_st}'
    EVP_MD_CTX ctx;
               ^~~

and so on. consider porting to openssl 1.1 or switching to compat-openssl10.

Comment 1 Igor Gnatenko 2017-01-13 06:58:27 UTC
I think switching to compat-openssl10 due to upstream:
~0007451

kern	(administrator)

2016-12-28 11:54
	At the moment we are not ready to support the new version of OpenSSL. 

http://bugs.bacula.org/view.php?id=2247 (anonymous / anonymous)