Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1415796

Summary: Palm rejection doesn't work quite well enough, even while typing
Product: [Fedora] Fedora Reporter: Andy Lutomirski <luto>
Component: libinputAssignee: Peter Hutterer <peter.hutterer>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: peter.hutterer
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libinput-1.6.3-4.fc25 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-12 12:05:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
evemu recording of spurious touch none

Description Andy Lutomirski 2017-01-23 18:18:18 UTC
Created attachment 1243747 [details]
evemu recording of spurious touch

I captured the attached evemu recording on my XPS 13 9350 while actively typing.  In the middle of typing a word, libinput reported a touch, screwing up my emacs session :(  This recording contains no intentional interaction with the touchpad at all.

I don't know if this is a libinput bug, a driver issue, a firmware issue, or some combination thereof, but I thought that libinput was supposed to have good filtering for this kind of glitch, especially while actively typing.

Comment 1 Peter Hutterer 2017-05-09 02:51:51 UTC
doh, sorry, this one slipped through. still there with 1.7.2, looks like the basic problem is that you're accidentally triggering a tap at the very far edge of the touchpad. that causes the button event, need to figure out how to deal with that.

Comment 2 Fedora Update System 2017-05-09 05:38:05 UTC
libinput-1.7.2-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f0beed1842

Comment 3 Fedora Update System 2017-05-09 05:53:49 UTC
libinput-1.6.3-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-aa77f1e01e

Comment 4 Fedora Update System 2017-05-10 07:04:20 UTC
libinput-1.6.3-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-aa77f1e01e

Comment 5 Fedora Update System 2017-05-12 02:11:16 UTC
libinput-1.7.2-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f0beed1842

Comment 6 Fedora Update System 2017-05-12 12:05:04 UTC
libinput-1.6.3-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2017-05-12 14:12:31 UTC
libinput-1.7.2-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.