Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at

Bug 1424166

Summary: python-matplotlib: testsuite failure in rawhide
Product: [Fedora] Fedora Reporter: Fedora Release Engineering <releng>
Component: python-matplotlibAssignee: Thomas Spura <tomspur>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 26CC: cstratak, dominik, gwync, jonathan.underwood, jspaleta,, python-sig, tomspur
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-03-09 22:09:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1423041    
Description Flags
state.log none

Description Fedora Release Engineering 2017-02-17 16:08:48 UTC
Your package python-matplotlib failed to build from source in current rawhide.

For details on mass rebuild see

Comment 1 Fedora Release Engineering 2017-02-17 16:09:04 UTC
Created attachment 1253787 [details]

Comment 2 Fedora Release Engineering 2017-02-17 16:09:10 UTC
Created attachment 1253788 [details]

Comment 3 Fedora Release Engineering 2017-02-17 16:09:15 UTC
Created attachment 1253789 [details]

Comment 4 Dominik 'Rathann' Mierzejewski 2017-02-21 01:00:28 UTC
One new test failure, could be ppc64-only:
FAIL: Github issue #1256 identified a bug in Line.draw method
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/nose/", line 197, in runTest
  File "/builddir/build/BUILDROOT/python-matplotlib-2.0.0-2.fc26.1.ppc64/usr/lib64/python2.7/site-packages/matplotlib/testing/", line 155, in wrapped_callable
    func(*args, **kwargs)
  File "/builddir/build/BUILDROOT/python-matplotlib-2.0.0-2.fc26.1.ppc64/usr/lib64/python2.7/site-packages/matplotlib/tests/", line 62, in test_invisible_Line_rendering
    assert_true(slowdown_factor < slowdown_threshold)
AssertionError: False is not true

Comment 5 Fedora End Of Life 2017-02-28 11:59:53 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.

Comment 6 Thomas Spura 2017-03-09 22:09:51 UTC
A simple rebuild seems to have worked:
There was a failure on x86_64, which was passing in another rebuild afterwards on F27. The build on F26 worked in the first try: