Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1429245

Summary: Massive display corruption in blender with radeon driver / Gnome Xorg session
Product: [Fedora] Fedora Reporter: ell1e <el>
Component: blenderAssignee: Luya Tshimbalanga <luya_tfz>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 25CC: design-devel, hobbes1069, jochen, kwizart, luya_tfz, negativo17, promac
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-03-06 13:44:29 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
glxinfo none

Description ell1e 2017-03-05 21:32:54 UTC
Created attachment 1260204 [details]
glxinfo

Description of problem:
I observe massive display corruption in blender with radeon driver / Gnome Xorg session:

The whole interface seems to blink back and forth (triggered by moving he mouse around) between the current state and some state it had before the last interaction. As a result, when clicking a button or doing something that greatly changes the view, the interface will then blink back and forth wildly between the new state it should be in and what I saw before that interaction. Since the UI consistently reacts to the new state even when the old one blinks in between, this seems to be purely some sort of render corruption rather than some actual UI bug.

Version-Release number of selected component (if applicable):
[jonas@falcon ~]$ blender --version
Blender 2.78 (sub 0)
	build date: 2017-02-13
	build time: 20:34:46
	build commit date: 1970-01-01
	build commit time: 00:00
	build hash: unknown
	build platform: Linux
	build type: Release
	build c flags:  -Wall -Wcast-align -Werror=implicit-function-declaration -Werror=return-type -Werror=vla -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wlogical-op -Wundef -Winit-self -Wnonnull -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Wformat-signedness -Wuninitialized -Wredundant-decls -Wshadow -Wno-error=unused-but-set-variable -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic  -fuse-ld=gold -fopenmp -std=gnu11   -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing -msse2
	build c++ flags:  -Wredundant-decls -Wall -Wno-invalid-offsetof -Wno-sign-compare -Wlogical-op -Winit-self -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Werror=return-type -Werror=implicit-function-declaration -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wundef -Wformat-signedness -Wuninitialized -Wundef -Wmissing-declarations -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic  -fuse-ld=gold -fopenmp -std=c++11   -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing -msse2
	build link flags: 
	build system: CMake

How reproducible:
100%, just launch blender and click something to trigger a UI state

Steps to Reproduce:
1. Launch blender
2. Change the view / open a file / rotate the view / ... do anything that would require the UI to change

Actual results:
UI and views update correctly

Expected results:
UI and views update but blink back and forth with older previous state


Additional info:

Comment 1 ell1e 2017-03-05 21:35:30 UTC
For what it's worth, this effect is always limited to purely the contents of the blender window itself. So it doesn't seem to be the gfx driver freaking out as a whole, but some blender-related problem.

Comment 2 Simone Caronni 2017-03-06 13:44:29 UTC

*** This bug has been marked as a duplicate of bug 1425146 ***