Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1429753

Summary: Appears to be a dependency issue with update as of 2017-03-05(06)
Product: [Fedora] Fedora Reporter: James Crawford <jrefl5>
Component: kdepimAssignee: Than Ngo <than>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 24CC: houder, jreznik, luton, magnus.tuominen, me, randy, rdieter, smparrish, than, urilabob
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: kdepim-16.12.2-3.fc24 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-03-11 11:50:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
broken dependency list none

Description James Crawford 2017-03-07 02:32:42 UTC
I had to select activitmanager inorder to submit the bug.

dnf -y upgrade on system this AM (158 updates)

Screensaver /lock kicked in and produces an error message.

rebooted system to attempt to login unable to login into Kdesktop.

switched to VT(F2) and loged in as root

dnf -y upgrade --refresh
>> reports 20 packages skipped due to broken dependencies

Attempted to revert the update
>dnf history undo 115
>>reports
No package kdepimlibs-kxmlrpcclient-0:4.14.10-15.fc24.x86_64 available.
Error: An operation cannot be undone.


I can provide DNF log if needed.

Comment 1 Randy Barlow 2017-03-07 22:51:28 UTC
Created attachment 1261006 [details]
broken dependency list

I believe I am also experiencing this issue on Fedora 24, and it seems to be broader than just kde-plasma-activitymanager. I've attached the output of dnf showing a list of broken dependencies.

Comment 2 Randy Barlow 2017-03-07 22:58:12 UTC
I'm adding Rex to CC, in case we need to change the component of this bug to be more general to KDE.

Comment 3 Fedora Update System 2017-03-08 00:58:39 UTC
kdepim-16.12.2-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-81bed9e1d4

Comment 4 Fedora Update System 2017-03-08 01:03:43 UTC
kdepim4-4.14.10-27.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-daa782e4a0

Comment 5 James Crawford 2017-03-08 02:00:30 UTC
Looks like todays updates did the trick, at least for me as of 15 min ago.

Thanks

Comment 6 Henri 2017-03-08 14:02:34 UTC
@Randy Barlow (see comment #1): this problem is definitely broader than the pkg to which James Crawford refers (kde-plasma-activitymanager) ... the latter is not installed here (some month ago I installed the KDE spin of Fedora 24).

After my 1st attempt to upgrade on March 6 (lots and lots of "kde" pkgs), my gui failed in part. One day later dnf reported more "kde" packages. After installing those, my gui problem had disappeared. However I ended up with the same list of "skipped pkgs because of broken dependencies" as you did.

Btw, the upgrade on March 6 was NOT the first one after installing Fedora 24; I regularly upgrade my system (every other day) ...

Comment 7 Henri 2017-03-08 16:32:14 UTC
After studying the output of "dnf -b upgrade <pkg>" for each of the skipped pkgs, I decided to carry out the two following upgrades:

 1. dnf -b --allowerasing upgrade gpgme
 2. dnf -b --allowerasing upgrade knotes-libs

The 1st one upgraded 18 of the skipped packages (removing kdepim-common, kdepim-libs, knode and knode-libs ... and installing 10 others).

The 2nd one "upgraded" the last of the skipped pkgs (however in reality, it reinstalled knotes-libs and knotes - sigh).

After that "dnf check-update" was silent (no skipped pkgs).

To me, upgrading (using dnf) is turning into "magic" this way ...

Comment 8 Rex Dieter 2017-03-08 16:43:29 UTC
There should really be nothing magic here, it's just that the previous kdepim-16.12.2 related update missed 2 packages (sorry).  Those 2 packages are now submitted as updates themselves, see comment #3  and comment #4 (each of which are currently available in updates-testing).  Once they land in stable updates, everything should 'just work', normal update mechanisms will pick them up, and dependency issues should be resolved.

Comment 9 Henri 2017-03-08 17:27:29 UTC
(In reply to Henri from comment #7)
> After studying the output of "dnf -b upgrade <pkg>" for each of the skipped
> pkgs, I decided to carry out the two following upgrades:
> 
>  1. dnf -b --allowerasing upgrade gpgme
>  2. dnf -b --allowerasing upgrade knotes-libs
> 
> The 1st one upgraded 18 of the skipped packages (removing kdepim-common,
> kdepim-libs, knode and knode-libs ... and installing 10 others).
> 
> The 2nd one "upgraded" the last of the skipped pkgs (however in reality, it
> reinstalled knotes-libs and knotes - sigh).
> 
> After that "dnf check-update" was silent (no skipped pkgs).
> 
> To me, upgrading (using dnf) is turning into "magic" this way ...

Correcting myself: knotes-libs was upgraded, knotes was installed.

Comment 10 Henri 2017-03-08 17:38:22 UTC
@Rex Dieter: Thank you for clarifying what is going on. Obviously, the whole "string of events" is no magic to you, but it is to me -- as I wrote (I am just a regular user, not an expert -- and I could not make head or tail of what had gone wrong with my upgrade).

Comment 11 bob mckay 2017-03-08 21:33:34 UTC
Hi Rex, and thank you for fixing this. I notice that the issue didn't seem to arise for F25. Does this mean that updates are (presumably automatically) tested against F25, but maybe not F24?

Comment 12 Fedora Update System 2017-03-11 11:50:37 UTC
kdepim-16.12.2-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2017-03-11 11:50:47 UTC
kdepim4-4.14.10-27.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Luke 2017-03-12 03:20:03 UTC
I've just sudo dnf upgraded F24. There were no broken dependencies this time and everything works!