Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1430302

Summary: Double click on a docx, xlsx or pptx files extracts files instead of launching Libreoffice
Product: [Fedora] Fedora Reporter: Paul Scott <paulsscott>
Component: nautilusAssignee: Matthias Clasen <mclasen>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: awilliam, cegolf, cosimo.cecchi, csoriano, klember, kparal, mclasen, mruckman, robatino, rwf, simon.arnaud, ulf.gunnarson
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-03-27 16:27:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1349185, 1349188    

Description Paul Scott 2017-03-08 10:35:04 UTC
Description of problem:

Since very recently (can't be precise) double clicking on a docx, xlsx, or pptx file in files causes Nautilus to extract the files to a directory instead of launching Libreoffice. This despite the fact that Libreoffice Writer/Calc/Present is set as default application.

Version-Release number of selected component (if applicable):
Fedora 25, Gnome 3.22.2 Libreoffice 5.2.6.2

How reproducible:
Every time, on separately installed computers. Affects a colleague that runs F25. Doesn't affect another colleague that runs Debian with Gnome 3.22.2

Steps to Reproduce:
1. Open Files
2. Find a docx, xlsx file
3. Double click

Actual results:
Unpacks the file, creating a directory.

Expected results:
Launch Libreoffice

Additional info:

Comment 1 Simon Arnaud 2017-03-10 13:18:42 UTC
Reported upstream also :

https://bugzilla.gnome.org/show_bug.cgi?id=779795

Comment 2 Rob Foehl 2017-03-10 22:38:57 UTC
Until it's fixed for specific filetypes (and/or depending on overall preference) you can disable this entirely by unchecking 'Extract the files on open' in Nautilus Preferences -> Behavior, or by running:

╶➤ gsettings set org.gnome.nautilus.preferences automatic-decompression false

...which I believe I'll keep, because this is just obnoxious.  Who wants random archive contents spilled all over their disks?

Comment 3 Paul Scott 2017-03-11 06:48:19 UTC
Thanks for the workaround, which I believe I'll keep too.

Comment 4 Simon Arnaud 2017-03-13 10:43:25 UTC
Perfect workaround.

Maybe it should be the default. I see the upstream bug has a lenghty discussion.

Comment 5 Kamil Páral 2017-03-21 08:13:32 UTC
I can confirm this on Fedora 25 and Fedora 26 with nautilus-3.23.92-1.fc26.x86_64.

Proposing as a blocker for F26 under:
"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."
https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria#Default_application_functionality

It is expected that you can double-click MS Office files in your file manager and LibreOffice opens up. Opening up files in applications is considered a basic functionality by me.

As an anecdote, my wife discovered this problem a few days ago and was utterly confused that she clicked a document and "something wrong happened" - not only LibreOffice was not opened up, but "something was messed up in her folder" (in a folder with lots of files, you won't likely notice that the docx/xlsx/pptx file was extracted into a new folder, since the current auto-extract functionality is not very obvious, you just know something changed, files jumped positions - and you'll be confused when you find the extracted directory sometime later and won't know what it is).

Comment 6 Fedora Update System 2017-03-21 14:13:38 UTC
gnome-autoar-0.2.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-072b0ab1b5

Comment 7 Fedora Update System 2017-03-21 14:13:56 UTC
gnome-autoar-0.2.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e6e9dd4432

Comment 8 Kalev Lember 2017-03-21 14:16:55 UTC
Proposing as Alpha freeze exception. This is a low risk bug fix, fixing an embarrassing issue that reviewers might discover when testing Workstation live media.

Not super important to get in, but might be nice.

Comment 9 Kamil Páral 2017-03-21 14:24:02 UTC
(In reply to Fedora Update System from comment #7)
> gnome-autoar-0.2.2-1.fc26 has been submitted as an update to Fedora 26.
> https://bodhi.fedoraproject.org/updates/FEDORA-2017-e6e9dd4432

Fixes the problem.

Comment 10 Fedora Update System 2017-03-22 00:53:12 UTC
gnome-autoar-0.2.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-072b0ab1b5

Comment 11 Fedora Update System 2017-03-22 15:26:58 UTC
gnome-autoar-0.2.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e6e9dd4432

Comment 12 Fedora Update System 2017-03-22 19:22:03 UTC
gnome-autoar-0.2.2-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Kalev Lember 2017-03-24 09:57:02 UTC
Reopening for F26 freeze exception consideration.

Comment 14 Mike Ruckman 2017-03-27 04:34:56 UTC
+1 FE.

Comment 15 Adam Williamson 2017-03-27 04:36:49 UTC
I'm +1 FE on this too, seems reasonable.

Comment 16 Kevin Fenzi 2017-03-27 04:39:44 UTC
+1 FE

Comment 17 Adam Williamson 2017-03-27 04:40:18 UTC
That's +3 FE, marking accepted.

Comment 18 Paul Scott 2017-03-27 06:37:16 UTC
gnome-autoar-0.2.2-1.fc25 fixes the problem for me too. Thanks.

Comment 19 Fedora Update System 2017-03-27 16:27:56 UTC
gnome-autoar-0.2.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Adam Williamson 2017-04-04 19:10:34 UTC
As this is fixed in F25 and F26, don't think it needs commonbugs.