Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1451220

Summary: /dev/port is missing
Product: [Fedora] Fedora Reporter: old_man999
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: gansalmon, ichavero, itamar, jonathan, kernel-maint, labbott, madhu.chinakonda, mchehab, odslabs, old_man999, robert.hancock, zlynx
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: kernel-4.11.11-300.fc26 kernel-4.11.12-100.fc24 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-07-26 21:19:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description old_man999 2017-05-16 07:11:17 UTC
/dev/port went missing in kernel 4.10.12.
I think this is not by design because at least some tools depend on it?

Reproducable: always

Comment 1 Laura Abbott 2017-05-16 16:45:09 UTC
Can you explain what is broken for you by not having /dev/port on?

Comment 2 old_man999 2017-05-17 21:46:20 UTC
I use this to control the fanspeed of my HP Probook (BIOS has no good settings regarding this): https://github.com/k3mpaxl/fanspeed/blob/master/probook_ec.pl
This relies on /dev/port. So no standard use case.
Maybe I have to find another way then if possible.

Comment 3 old_man999 2017-05-19 17:20:38 UTC
*** Bug 1451219 has been marked as a duplicate of this bug. ***

Comment 4 Jonathan Briggs 2017-05-31 06:41:53 UTC
Also sensors-detect from lm_sensors no longer works. It requires /dev/port to locate the ISA sensors.

Comment 5 Beshoy 2017-06-30 07:45:01 UTC
I also ran across the file missing when trying to run https://github.com/nagisa/msi-rgb.

Comment 6 old_man999 2017-07-02 21:17:51 UTC
I solved my issue by finding a software that rather uses the "ec_sys" kernel module for that particular purpose: https://github.com/hirschmann/nbfc/blob/master/Core/Plugins/StagWare.Plugins.ECSysLinux/ECSysLinux.cs

Comment 7 Robert Hancock 2017-07-12 16:28:20 UTC
Confirmed that sensors-detect in lm_sensors is broken due to this issue, on Fedora 26 as well.

Comment 8 Fedora Update System 2017-07-18 00:04:28 UTC
kernel-4.11.11-300.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-deb70b495e

Comment 9 Fedora Update System 2017-07-18 00:05:51 UTC
kernel-4.11.11-200.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-98548b066b

Comment 10 Fedora Update System 2017-07-18 00:07:01 UTC
kernel-4.11.11-100.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b4df78b4b2

Comment 11 Fedora Update System 2017-07-19 03:51:10 UTC
kernel-4.11.11-100.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b4df78b4b2

Comment 12 Fedora Update System 2017-07-19 04:25:49 UTC
kernel-4.11.11-200.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-98548b066b

Comment 13 Fedora Update System 2017-07-20 00:25:22 UTC
kernel-4.11.11-300.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-deb70b495e

Comment 14 Fedora Update System 2017-07-23 03:56:49 UTC
kernel-4.11.11-300.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2017-07-23 22:54:47 UTC
kernel-4.11.11-200.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2017-07-24 14:08:16 UTC
kernel-4.11.12-100.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-544eef948f

Comment 17 Fedora Update System 2017-07-25 01:52:00 UTC
kernel-4.11.12-100.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-544eef948f

Comment 18 Fedora Update System 2017-07-26 21:19:22 UTC
kernel-4.11.12-100.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.