Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1482692

Summary: gi.overrides.BlockDev.LVMError: Failed to call the 'Activate' method on the '/com/redhat/lvmdbus1/Lv/0' object: GDBus.Error:org.freedesktop.DBus.Python.dbus.exceptions.DBusException: ('com.redhat.lvmdbus1.Lv', 'Exit code 5, stderr = Volume group ...
Product: [Fedora] Fedora Reporter: Joachim Frieben <jfrieben>
Component: libblockdevAssignee: Vratislav Podzimek <vpodzime>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 27CC: anaconda-maint-list, g.kaviyarasu, jfrieben, jkonecny, jonathan, kparal, mkolman, robatino, sbueno, vanmeeuwen+fedora, vpodzime, vponcova, vtrefny
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:263351e701884e54bad3243647566b305a62af14a761cd59a28238e56b4f1c77;
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-10-04 08:13:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1396704, 1396705    
Attachments:
Description Flags
File: anaconda-tb
none
File: anaconda.log
none
File: dnf.librepo.log
none
File: environ
none
File: hawkey.log
none
File: lorax-packages.log
none
File: lsblk_output
none
File: lvm.log
none
File: nmcli_dev_list
none
File: os_info
none
File: program.log
none
File: storage.log
none
File: syslog
none
File: ifcfg.log
none
File: packaging.log none

Description Joachim Frieben 2017-08-17 21:45:36 UTC
Version-Release number of selected component:
anaconda-27.20-1

The following was filed automatically by anaconda:
anaconda 27.20-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/gi/overrides/BlockDev.py", line 824, in wrapped
    raise transform[1](msg)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1966, in _setup
    blockdev.lvm.lvactivate(self.vg.name, self._name)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1839, in decorated
    return meth(self, *args, **kwargs)  # pylint: disable=not-callable
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 377, in setup
    self._setup(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1936, in setup
    return DMDevice.setup(self, orig)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1839, in decorated
    return meth(self, *args, **kwargs)  # pylint: disable=not-callable
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/deviceaction.py", line 695, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 325, in process
    action.execute(callbacks)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 48, in wrapped_func
    return func(obj, *args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 163, in do_it
    self.devicetree.actions.process(callbacks=callbacks, devices=self.devices)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/osinstall.py", line 1112, in turn_on_filesystems
    storage.do_it(callbacks)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 438, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 472, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation.py", line 365, in doInstall
    installation_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threading.py", line 252, in run
    threading.Thread.run(self)
gi.overrides.BlockDev.LVMError: Failed to call the 'Activate' method on the '/com/redhat/lvmdbus1/Lv/0' object: GDBus.Error:org.freedesktop.DBus.Python.dbus.exceptions.DBusException: ('com.redhat.lvmdbus1.Lv', 'Exit code 5, stderr =   Volume group "VolGroup00" not found\n  Cannot process volume group VolGroup00\n')

Additional info:
addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/libexec/system-python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-WS-dvd-x86_64-rawh quiet kaslr enforcing=0
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.13.0-0.rc4.git4.1.fc27.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide

Comment 1 Joachim Frieben 2017-08-17 21:46:03 UTC
Created attachment 1314916 [details]
File: anaconda-tb

Comment 2 Joachim Frieben 2017-08-17 21:46:06 UTC
Created attachment 1314917 [details]
File: anaconda.log

Comment 3 Joachim Frieben 2017-08-17 21:46:09 UTC
Created attachment 1314918 [details]
File: dnf.librepo.log

Comment 4 Joachim Frieben 2017-08-17 21:46:10 UTC
Created attachment 1314919 [details]
File: environ

Comment 5 Joachim Frieben 2017-08-17 21:46:12 UTC
Created attachment 1314920 [details]
File: hawkey.log

Comment 6 Joachim Frieben 2017-08-17 21:46:14 UTC
Created attachment 1314921 [details]
File: lorax-packages.log

Comment 7 Joachim Frieben 2017-08-17 21:46:16 UTC
Created attachment 1314922 [details]
File: lsblk_output

Comment 8 Joachim Frieben 2017-08-17 21:46:20 UTC
Created attachment 1314923 [details]
File: lvm.log

Comment 9 Joachim Frieben 2017-08-17 21:46:21 UTC
Created attachment 1314924 [details]
File: nmcli_dev_list

Comment 10 Joachim Frieben 2017-08-17 21:46:23 UTC
Created attachment 1314925 [details]
File: os_info

Comment 11 Joachim Frieben 2017-08-17 21:46:25 UTC
Created attachment 1314926 [details]
File: program.log

Comment 12 Joachim Frieben 2017-08-17 21:46:30 UTC
Created attachment 1314927 [details]
File: storage.log

Comment 13 Joachim Frieben 2017-08-17 21:46:37 UTC
Created attachment 1314928 [details]
File: syslog

Comment 14 Joachim Frieben 2017-08-17 21:46:39 UTC
Created attachment 1314929 [details]
File: ifcfg.log

Comment 15 Joachim Frieben 2017-08-17 21:46:41 UTC
Created attachment 1314930 [details]
File: packaging.log

Comment 16 Jiri Konecny 2017-08-21 10:59:19 UTC
This looks as a storage related bug.

Changing components.

Comment 17 Fedora Blocker Bugs Application 2017-10-01 07:52:39 UTC
Proposed as a Blocker and Freeze Exception for 27-final by Fedora user frieben using the blocker tracking app because:

 Anaconda fails to process a LUKS-encrypted volume group after the setup stage even though the password had been entered successfully, and individual volumes had been assigned when specifying the disk layout. The installer aborts and leaves the user with an unbootable system because this happens after reformatting the unencrypted /boot partition. This behaviour violates the following requirement:

"The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration."

Comment 18 Kamil Páral 2017-10-02 16:58:13 UTC
Discussed at blocker review meeting [1]:

Punt (delay decision) - We'll wait until this has detailed reproduction steps and somebody else manages to successfully reproduce it.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-10-02/