Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1491006

Summary: OSError: Unable to create user 123: status=3
Product: [Fedora] Fedora Reporter: vwvtkxjobkvpqszygxmjvgaavwvfju
Component: anacondaAssignee: Vendula Poncova <vponcova>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 26CC: anaconda-maint-list, awilliam, dlehman, groeneboerderij, jkonecny, jonathan, kellin, mboddu, mkolman, pjones, sbueno, thegobinath, vanmeeuwen+fedora, vpodzime, vponcova, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:2b39722c65a885ff8d69f70c87e4c3966efbf3e886ee3768f78c254d8cc357a1;VARIANT_ID=workstation; AcceptedFreezeException
Fixed In Version: anaconda-27.20.3-1 anaconda-27.20.4-1.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-10-18 15:22:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1396705    
Attachments:
Description Flags
File: anaconda-tb
none
File: anaconda.log
none
File: environ
none
File: journalctl
none
File: lsblk_output
none
File: lvm.log
none
File: nmcli_dev_list
none
File: os_info
none
File: program.log
none
File: storage.log
none
File: ifcfg.log
none
File: packaging.log none

Description vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:10 UTC
Description of problem:
1. Started VirtualBox version 5.1.26 r117224 (Qt5.6.2) on Windows 10 1703
2. Create a new virtual machine; 2048 MB RAM; 16 GB dynamic disk; EFI system checked in the options; rest default
3. Boot installer
4. From the "try/install" popup, select install
5. Set locale to enGB
6. Auto detect timezone to EU/Amsterdam
7. Use automatic partitioning (problem happens when reclaiming the disk, and when using a clean disk)
8. Set root password to '123'
9. Set user and user password both to '123'
10. The installer fails after installing the system, at 'Creating users'

Version-Release number of selected component:
anaconda-core-26.21.11-1.fc26.x86_64

The following was filed automatically by anaconda:
anaconda 26.21.11-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/pyanaconda/users.py", line 404, in createUser
    raise OSError("Unable to create user %s: status=%s" % (user_name, status))
  File "/usr/lib64/python3.6/site-packages/pyanaconda/kickstart.py", line 1825, in execute
    users.createUser(usr.name, **kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 437, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 471, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 303, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 303, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install.py", line 194, in doConfiguration
    configuration_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threads.py", line 251, in run
    threading.Thread.run(self)
OSError: Unable to create user 123: status=3

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz root=live:CDLABEL=Fedora-WS-Live-26-1-5 rd.live.image quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.8-300.fc26.x86_64
other involved packages: system-python-libs-3.6.1-8.fc26.x86_64
product:        Fedora
release:        Fedora release 26 (Twenty Six)
type:           anaconda
version:        26

Comment 1 vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:22 UTC
Created attachment 1324985 [details]
File: anaconda-tb

Comment 2 vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:24 UTC
Created attachment 1324986 [details]
File: anaconda.log

Comment 3 vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:26 UTC
Created attachment 1324987 [details]
File: environ

Comment 4 vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:30 UTC
Created attachment 1324988 [details]
File: journalctl

Comment 5 vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:32 UTC
Created attachment 1324989 [details]
File: lsblk_output

Comment 6 vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:35 UTC
Created attachment 1324990 [details]
File: lvm.log

Comment 7 vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:37 UTC
Created attachment 1324991 [details]
File: nmcli_dev_list

Comment 8 vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:39 UTC
Created attachment 1324992 [details]
File: os_info

Comment 9 vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:41 UTC
Created attachment 1324993 [details]
File: program.log

Comment 10 vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:44 UTC
Created attachment 1324994 [details]
File: storage.log

Comment 11 vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:46 UTC
Created attachment 1324995 [details]
File: ifcfg.log

Comment 12 vwvtkxjobkvpqszygxmjvgaavwvfju 2017-09-12 18:09:48 UTC
Created attachment 1324996 [details]
File: packaging.log

Comment 13 Vendula Poncova 2017-09-19 08:52:08 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/1192

Comment 14 Fedora Update System 2017-10-12 17:20:40 UTC
anaconda-27.20.4-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-fe6c2736ca

Comment 15 Fedora Update System 2017-10-13 23:22:50 UTC
anaconda-27.20.4-1.fc27, pykickstart-2.40-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-fe6c2736ca

Comment 16 Adam Williamson 2017-10-17 17:28:39 UTC
Proposing as a Final freeze exception - this is an undesirable installer behaviour, obviously cannot be fixed with an update.

Comment 17 Dennis Gilmore 2017-10-17 17:41:00 UTC
+1 FE

Comment 18 Mohan Boddu 2017-10-17 17:41:53 UTC
+1 FE

Comment 19 Adam Williamson 2017-10-17 18:20:43 UTC
That's +3, setting accepted.

Comment 20 Fedora Update System 2017-10-18 15:22:20 UTC
anaconda-27.20.4-1.fc27, pykickstart-2.40-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Vendula Poncova 2017-11-20 10:18:08 UTC
*** Bug 1471530 has been marked as a duplicate of this bug. ***

Comment 22 Vendula Poncova 2017-11-20 10:23:23 UTC
*** Bug 1405823 has been marked as a duplicate of this bug. ***